0

After a recent power failure, my Fedora linux system resets during the boot process and then boots again. It does not appear to be a kernel panic (no panic messages on the console) or an orderly shutdown. It is as if the reset button was pressed.

I can boot into single user mode successfully. The file systems appear intact. It seems to reset just before X is started (the date on the /var/log/Xorg.0.log file is old). It will boot a live CD into multi user mode and start X just fine. I have replaced the video card and power supply and tested the RAM (memtest overnight).

I suspect it has something to do with the software, but not 100% sure. I have backups, but have no idea where to look. The last thing in the /var/log/messages file is the avahi daemon finishing it's startup and one acipd log message. I have checked all of the files in /lib/modules and /usr/lib64/xorg/modules and they match the backups (even going back to backups before the last successful boot of this machine).

Some suggestions as to how to proceed in diagnosing this would be welcome.

  • You might try removing any quiet or splash options being passed to the kernel on boot. Ideally, you'd see a bunch of normal boot-time status messages, which might well show more detail. – Tom Hunt Nov 18 '15 at 16:49
  • Which version of fedora are you using, and also what hardware? – Wilf Nov 18 '15 at 16:55
  • Can you comment the Fedora version? – X3MBoy Nov 18 '15 at 17:00
  • Try to start X from console – gena2x Nov 18 '15 at 18:00
  • This is an old Fedora 8 system. – Jay Nov 18 '15 at 19:18
1

I have managed to resolve this by disabling the nagios service. I switched to a different motherboard and instead of resetting, the system appeared to hang and the HDD LED was solid on. After a while, I did get a login prompt and was able to log in, but the system was very very slow (ie, busy). I tried shutting it down, and it looked like nagios was stuck somewhere. After removing it's startup link in /etc/rc5.d, the system boots normally again. I am no longer using nagios on this system, so that is a solution for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.