6

I'm on Manjaro and today I woke up to find my computer having problems due to a full disk. I have deleted many things but this did not solve the issue. I have no idea what is happening. Is there a way to repartition fast? Cause I don't have Gparted live CD at hand.

Here is the full partition:
enter image description here

But the filesystem is not full:
enter image description here

Here is the output of df -ah (with virtual file systems omitted)

Filesystem                         Size  Used Avail Use% Mounted on
/dev/mapper/ManjaroVG-ManjaroRoot   29G   29G     0 100% /
/dev/sda1                          247M   56M  179M  24% /boot
/dev/mapper/ManjaroVG-ManjaroHome  550G  296G  227G  57% /home

Here is the output of df -i for the same partitions: ~/Desktop

Filesystem                          Inodes  IUsed    IFree IUse% Mounted on
/dev/mapper/ManjaroVG-ManjaroRoot  1921360 441275  1480085   23% /
/dev/sda1                            65280    368    64912    1% /boot
/dev/mapper/ManjaroVG-ManjaroHome 36626432 320911 36305521    1% /home

As a result of my full partition, mysql fails to start.

Here is the output of lsblk:

NAME                      MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda                         8:0    0 596.2G  0 disk 
├─sda1                      8:1    0   255M  0 part /boot
└─sda2                      8:2    0 595.9G  0 part 
  ├─ManjaroVG-ManjaroRoot 254:0    0  29.3G  0 lvm  /
  ├─ManjaroVG-ManjaroHome 254:1    0 558.9G  0 lvm  /home
  └─ManjaroVG-ManjaroSwap 254:2    0   7.8G  0 lvm  [SWAP]
sr0                        11:0    1  1024M  0 rom  

And here is the output of du -shx /* (trimmed of extraneous entries)

54M /boot
3.2G    /data
19M /etc
296G    /home
4.0K    /media
4.0K    /mnt
1.1G    /opt
79M /root
1.1M    /run
16K /srv
28K /tmp
7.6G    /usr
14G /var

Drilling down into `/var/ shows the big disk space users are:

9.0G    /var/cache 
4.8G    /var/lib 
  • gparted will show it is all allocated as usable partitions. it itsn't aware of how much space is actually occupied by data. – Octopus Nov 19 '15 at 0:25
  • @Octopus true casey told me that in chat, he solved it all in chat and spent hours talking to me. had to open another Q for mysql and issue solved too unix.stackexchange.com/questions/243934/mysql-isnt-starting/… this community is really great – Lynob Nov 19 '15 at 8:18
8

Your partition /dev/sda2 shows up as "full" because it is entirely allocated to LVM, which is managing your / and /home partitions. We don't need to look directly at /dev/sda2 as a result, but rather your LVM configuration. We can see from your lsblk output:

└─sda2                      8:2    0 595.9G  0 part 
  ├─ManjaroVG-ManjaroRoot 254:0    0  29.3G  0 lvm  /
  ├─ManjaroVG-ManjaroHome 254:1    0 558.9G  0 lvm  /home
  └─ManjaroVG-ManjaroSwap 254:2    0   7.8G  0 lvm  [SWAP] 

that it is likely your entire LVM is allocated to ManjaroRoot, ManjaroHome and ManjaroSwap. This means that growing your partitions is not an option without either first adding a new LVM PV or shrinking an existing LVM LV (not a straightforward task). However, those options are treating the symptom and not the problem.

Your problem is that / on the device /dev/mapper/ManjaroVG-ManjaroRoot is full. Your /home partition is not full and is not relevant to your problem.

We can see from your du output that the largest disk usage under / are:

3.2G    /data
1.1G    /opt
7.6G    /usr
14G     /var

The usages for /data, /opt and /usr look reasonable but the outlier is /var which is using a ton of space.

Some updated information from you in chat shows this isn't a log issue as I suspected but rather a package cache issue with the pacman package cache. You can clean out old files from the cache with the command:

pacman -Sc 

You can read more about cleaning the package cache on the Arch wiki.

5

Your / is full. Probably a out of control /var/log, either ssh probes in messages/syslog, or mysql errors, and huge logs in /var/log/mysql.

The best course is to locate the offending files, understand what caused the errors, and delete them.

Then if the errors were understood, try to fix what caused them in the first place.

  • After long discussion with casey in chat, i freed 10gb almost from var/log pacman folder and lib, the issue still stands, latest error log pastebin.com/HFNvKDyd – Lynob Nov 18 '15 at 17:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.