1

I am trying to install Eclipse Mars on my ArchLinux, but the application won't start. I use gnome as my desktop environement.

So I tried to launch it in console:

eclipse -debug -consolelog

the log stop after this lines:

org.eclipse.m2e.logback.configuration: The org.eclipse.m2e.logback.configuration bundle was activated before the state location was initialized.  Will retry after the state location is initialized.
Starting application: 1954

My cpu run at background(30%) and it took 1G of nemory, but no application showed

I tried to download Eclipse Mars from the website but I had the same problem. I tried it with eclipse Luna and that worked, but I need to use eclipse Mars.

How can I start Eclipse Mars on ArchLinux?

  • Does eclipse -clean work? You might need to run it as root if you have plugins installed by root. – ams Nov 18 '15 at 13:03
  • no eclispe -clean don't work – olive007 Nov 19 '15 at 17:47
  • I installed eclipse from the Arch repository and it works fine. – ams Nov 19 '15 at 17:49
0

Ok, I found the problem. This didn't come form Eclipse Mars.

I used Gnome on wayland like desktop environement. I used that because my touchpad didn't work on Gnome. I folow instruction form this website To solve the touchpad problem:

I installed xf86-input-libinput drivers.

So, now I use Gnome and that's work. Thank for your help Thomas Dickey

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.