2

Objective

Obtain a full installation of FreeBSD 10.2-RELEASE on a MacBookPro 7,2.

Hardware

  • Intel Core 2 Duo, 2.4Ghz, 3Mb L2 Cache,
  • 4Gb Memory,
  • NVidia MCP89 AHCI SATA controller.

What has been done

The rEFInd 0.10.0 boot manager is installed and provide an EFI menu from which a FreeBSD 10.2-RELEASE amd64 memstick image is launched.

An acces to the loader(8) is provided, from which some parameters like disabling the ACPI support can be tweaked.

 set hint.acpi.0.disabled=1    

Result

The boot process hangs on the following console output

Starting bootx64.efi
Using load options ''

>> FreeBSD EFI boot block
   Loader path: /boot/loader.efi
Consoles: EFI console
Image base: 0xbfe58000
EFI version: 1.10
EFI Firmware: Apple (rev 1.10)

FreeBSD/amd64 EFI loader, Revision 1.1
(root@releng1.nyi.freebsd.org, Weg Aug 12 15:21:04 UTC 2015)
Loading /boot/defaults/load.conf
/boot/kernel/kernel text=0xfc8de8 data=0x1283b0+207880 syms=[0x8+0x145350+0x8+0x15fe20]

[37m [44mBooting... [m                 <==With non printable characters inside 
Start @ 0xffffffff802dfc70

Questions

  • How to boot FreeBSD 10.2-RELEASE on a MacBookPro 7,2?
  • Is the NVidia MCP89 AHCI SATA controller a problem?
  • Is ACPI a problem?
  • How to obtain more debugging information?

Known actual state

The FreeBSD wiki on MacBook says:

Recent MacBook Pro and Mac Mini with NVIDIA MCP89 cannot find SATA drives. Linux added a workaround (https://bugzilla.kernel.org/show_bug.cgi?id=15923) and we may need a similar hack until correct fixes are found.

and there is a patch

Do not force AHCI mode on NVIDIA MCP89 SATA controllers.  Recent Apple
Mac with this chipset does not initialize AHCI mode unless it is started
from EFI loader.  However, legacy ATA mode works.

Submitted by:   jkim@ (original version)
Approved by:    re (kib)
MFC after:  1 week

already included in FreeBSD 10.2

Ressources

2

You don't need rEFInd to boot your installer. Just download the UEFI image from:

ftp://ftp.freebsd.org/pub/FreeBSD/releases/amd64/amd64/ISO-IMAGES/10.2/FreeBSD-10.2-RELEASE-amd64-uefi-memstick.img

and create a bootable USB stick.

I have installed FreeBSD 10.2 on a Mac mini using UEFI installer.

  • I've tried your proposition, but I've obtained the same result as previously. – Ortomala Lokni Dec 15 '15 at 20:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.