It's my first time compiling a Linux kernel. Everything went well until I hit this problem. After I edit my /etc/fstab:

/etc/fstab screenshot

and edit etc/lilo.conf:

/etc/lilo.conf screenshot

I want to set the info about crux in lilo, so I run lilo and the system prompt:

lilo screenshot

Then I run:

modprobe dm-mode

Things seem fine, but when I reboot the OS I get:

boot screenshot

I have no idea how to fix the problem; the next time I use the ISO to reboot, I get the same problem:

boot screenshot


I set the root read-write in the lilo.conf, it seems that I can login, but the system still prompts that the / item is not found in the fstab. But I have already set it. And here is the prompt:

enter image description here

And what's more, when I reboot it, I can already login to the OS, but it still prompts the same error. And, when I open the /etc/fstab, I can find the / item in it. So, I wonder if I should notice the system about the change in the /etc/fstab -- but after long time searching the Internet, I found nothing about it.

migrated from stackoverflow.com Nov 11 '11 at 3:55

This question came from our site for professional and enthusiast programmers.

  • Why did you mount your root read-only? – sarnold Nov 11 '11 at 3:44
  • read-only is just default set – kaiwii ho Nov 11 '11 at 3:45
  • i donn't know yet,maybe i choose some unrelated tags,but someone can help me about this problem yet? – kaiwii ho Nov 11 '11 at 3:48
  • i set the root read-write in the lilo.conf,it seems that i can login,but the system stiil prompt that the / item is not found in the fstab.But,anyway,i have set it before.someone can give me a hand?! – kaiwii ho Nov 11 '11 at 8:59
  • Can you take another screenshot of the error message about / not in fstab? – sarnold Nov 11 '11 at 9:20

I think I fixed it. I noticed when editing /etc/fstab in vim that one of the lines was red. I'm not very familiar with vim, but I think it was indicating some kind of mistake, so I rewrote the line:

vim screenshot

Now when I boot it works:

Screenshot of a successful boot

  • Do yourself a favor and switch to grub2; lilo is woefully outdated and hasn't seen a stable release in nearly 4 years. Even grub-legacy (grub-0.97) is better than lilo. – laebshade Nov 14 '11 at 2:22

Mostly over my head, but I noticed one small thing not related to your immediate problem.

/boot (on its own partition) is normally created as ext2 - not ext3 because it does not require any journaling - it's almost completely static and because it needs a tiny amount of disk space (somewhere around 100MB IIRC). The minimum size for an ext3 partition is larger than /boot needs and ext2 will do it. All that /boot normally holds is your kernel image and boot loader files like those needed by grub and probably lilo.

Changing this will free up a tiny amount of disk space for another partition to use, but shouldn't otherwise affect anything.

Some people recommend making /boot as large as 500MB, but that's probably overkill. YMMV.

  • Good advice on ext2 for /boot -- and 500 megs does seem a bit big, I've got nine currently installed kernels and 175 megs used. (Time to prune, I guess.) – sarnold Dec 23 '11 at 23:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.