0

I am trying to run an application which uses Qt on a Debian 7 server and I get the error message: This application failed to start because it could not find or load the Qt platform plugin "xcb". and when I run it with -platform offscreen: This application failed to start because it could not find or load the Qt platform plugin "offscreen".

I have tried following various fixes for ubuntu and Windows which didn't work for me, couldn't find any for Debian.

Any help would be appreciated

  • What fixes did you find for Ubuntu? Perhaps we can adapt them for Debian. – muru Nov 17 '15 at 14:37
0

Normally, when you install Qt via apt-get install libqt4-gui, the library libxcb.so gets pulled as a dependency. Try to run this command (again?), and if apt-get complains about any anomalies, try to fix them with apt-get -f install. Hopefully it will sort things out.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.