2

I am trying to install wireless drivers on my Dell Studio 1555 (as per these instructions).

In order to install the drivers the guide asks me to install dkms, which I did by running

sudo apt-get install dkms

Afterwards, the instructions say to enable the service by running sudo systemctl enable dkms. However, when I run this command, I get the following:

Failed to execute operation: No such file or directory

I have tried rebooting, with no change. What am I doing wrong?

Running systemctl status dkms.service produced the following output:

user@debian:~$ sudo systemctl status dkms.service
[sudo] password for user: 
● dkms.service
   Loaded: not-found (Reason: No such file or directory)
   Active: inactive (dead)
3
  • did you run sudo systemctl enable dkms ? can you edit your question and post the output of sudo systemctl status dkms.service?
    – LilloX
    Nov 17, 2015 at 8:56
  • dkms isn't a service. At least it isn't on debian. Installing linux-image-*, linux-headers-*, and *-dkms packages trigger dkms updates via their .postinst scripts on debian.
    – cas
    Nov 17, 2015 at 8:57
  • @LilloX done...
    – quant
    Nov 17, 2015 at 9:29

1 Answer 1

3

What am I doing wrong?

You're mixing operating systems.

You're following instructions written for Arch Linux on Debian Linux. Debian Linux packages dkms in a very different way to Arch Linux. Arch Linux uses a systemd service unit to load/unload DKMS kernel modules. Debian Linux uses modprobe.d files.

Use the doco of the operating system that you are actually using.

Further reading

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .