2

A few days ago, I was having some difficulty booting my Mint 17.2 installation. Essentially, after boot my screen would go black, and I would not be able to do anything - even after some time, the GUI would still not be loaded and I would be stuck with a simple, blank screen. This happened several times - prior to this, Mint was working just fine.

I booted into recovery mode, and ran a filesystem check, and I received several 'unexpected inconsistency' errors from both my root and home partitions. However, later on I was able to access the terminal using Ctrl-Alt-F2 and log into a maintenance shell. I tried searching for my problem online, and apparently the solution was to run the fsckutility with the -r option (I believe), and once I did that I found out that the cause of my problem was due to an unsynchronized hardware clock, and the root not being set to the same time as it. I was able to remedy that problem, and reboot successfully.

However, I am curious as how the time on my hardware is so essential for loading an OS successfully? Does anyone know how this works, and how I can avoid such a problem again in the future?

  • “I found out that the cause of my problem was due to an unsynchronized hardware clock”: what did you find out? What makes you think the clock was the problem? I don't recall seeing such problems on Linux. – Gilles 'SO- stop being evil' Nov 16 '15 at 22:57
0

Hardware clocks has a tendency to drift, either slowing or accelerating. When your system boots and checks your file system, it might find that the time stamps of your super block is in the future relatively to your system clock (if it slows a lot) and it will refuse to mount the file system without intervention.

To avoid this problem in the future, you should use NTP to synchronize your clock against a time server continuously. To do this, you can do the following:

$ sudo apt-get install ntp

This will install the ntp package and start the NTP daemon (which runs in the background and adjusts your clock).

To verify that it runs:

$ sudo service ntp status

It should output something like "* NTP server running".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.