0

I installed fglrx-updates on a fresh install of Mint 17.2 via this guide for Ubuntu 14.04. When I type in

$ fglrxinfo
display: :0  screen: 0
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD CAYMAN
OpenGL version string: 3.0 Mesa 10.1.3

I've tried purging it and reinstalling it as fglrx instead of fglrx-updates to no avail. If I type

$ amdcccle

It tells me that "There was a problem initializing Catalyst Control Center Linux edition. It could be caused by the following.

No AMD graphics driver is installed, or the AMD driver is not functioning properly. Please install the AMD driver appropriate for you AMD hardware, or configure using aticonfig."

I'm running an HD 6970.

0

This is what worked for me on Debian Jessie.

$ sudo /usr/lib/fglrx/switchlibGL amd

Afterwards amdcccle would work and fglrxinfo showed the change. My GPU also became available under OpenCL.

$ fglrxinfo 
display: :0.0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon HD 5800 Series
OpenGL version string: 4.5.13416 Compatibility Profile Context 15.302

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.