2

I am really frustrated here... My problem is that after some point (at first it worked correctly), a Digi Board I am using (with FTDI chipset) cannot be accessed through the serial (usb to serial) interface.

The device is attached at /dev/ttyUSB0. Every attempt to either cat /dev/ttyUSB0 or stty -F /dev/ttyUSB0 results in an Input/output error.

My OS is Linux Mint 17.2 (using 3.16.0-38 kernel).The output of dmesg when connecting the device is the following:

[ 1899.397283] usb 2-1.1: new full-speed USB device number 8 using ehci-pci
[ 1899.494395] usb 2-1.1: New USB device found, idVendor=0403, idProduct=6001
[ 1899.494403] usb 2-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 1899.494407] usb 2-1.1: Product: XBIB-U-SS
[ 1899.494411] usb 2-1.1: Manufacturer: FTDI
[ 1899.496323] ftdi_sio 2-1.1:1.0: FTDI USB Serial Device converter detected
[ 1899.496385] usb 2-1.1: Detected FT232RL
[ 1899.496389] usb 2-1.1: Number of endpoints 2
[ 1899.496392] usb 2-1.1: Endpoint 1 MaxPacketSize 64
[ 1899.496396] usb 2-1.1: Endpoint 2 MaxPacketSize 64
[ 1899.496399] usb 2-1.1: Setting MaxPacketSize 64
[ 1899.496828] usb 2-1.1: FTDI USB Serial Device converter now attached to ttyUSB0

If I try to access the port with Putty or with any of the before mentioned commands, I get input/output error and in dmesg is printing:

[ 2001.948650] usb 2-1.1: reset full-speed USB device number 8 using ehci-pci

The weird thing is that If try to open the port with any command or program within 1 second after plugging in the device, it works! If I close the program and try to start it again I get the same problem happens.

I tried searching for programs that get hold of the port with lsof /dev/ttyUSB0 and fuser /dev/ttyUSB0 , but nothing shows up! I also tried to reinstall the initial linux Mint kernel (3.13) but no result whatsoever! Can someone think of anything?

UPDATE: I tried connecting an exactly same device on my computer, and it works! At the same time if I connect the first one I get the same error. Please note that both devices operate normally on an other computer. So There has to be something set in my configuration that concerns the specific device (first one), but I do not know where to look...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.