1

I am trying to install Aforge Image Processing Lab on my Centos.

I configured my wine to 32bits like;

WINEARCH=win32 WINEPREFIX=~/.wine32 winecfg

And I install .NET 2.0 framework like;

env WINEARCH=win32 WINEPREFIX=~/.wine32 winetricks dotnet20

And also I install .exe file on ~/.wine32/drive_c/Program\ Files/ directory

Up to now, everything is quite good for me. However when I start;

wine iplab.exe

It gives me such error and it doesn't start;

[mg@MgCentOS bin]$ wine iplab.exe 
fixme:ntdll:find_reg_tz_info Can't find matching timezone information in the registry for bias -120, std (d/m/y): 8/11/2015, dlt (d/m/y): 29/03/2015

Unhandled Exception:
System.NotSupportedException: Can't get timezone name.
  at System.CurrentSystemTimeZone..ctor (Int64 lnow) [0x00000] in <filename unknown>:0 
  at System.TimeZone.get_CurrentTimeZone () [0x00000] in <filename unknown>:0 
  at System.DateTime.get_Now () [0x00000] in <filename unknown>:0 
  at System.Windows.Forms.TextBoxBase..ctor () [0x00000] in <filename unknown>:0 
  at System.Windows.Forms.TextBox..ctor () [0x00000] in <filename unknown>:0 
  at System.Windows.Forms.ComboBox+ComboTextBox..ctor (System.Windows.Forms.ComboBox owner) [0x00000] in <filename unknown>:0 
  at (wrapper remoting-invoke-with-check) System.Windows.Forms.ComboBox/ComboTextBox:.ctor (System.Windows.Forms.ComboBox)
  at System.Windows.Forms.ComboBox.set_DropDownStyle (ComboBoxStyle value) [0x00000] in <filename unknown>:0 
  at System.Windows.Forms.ComboBox..ctor () [0x00000] in <filename unknown>:0 
  at (wrapper remoting-invoke-with-check) System.Windows.Forms.ComboBox:.ctor ()
  at IPLab.HistogramWindow.InitializeComponent () [0x00000] in <filename unknown>:0 
  at IPLab.HistogramWindow..ctor () [0x00000] in <filename unknown>:0 
  at (wrapper remoting-invoke-with-check) IPLab.HistogramWindow:.ctor ()
  at IPLab.MainForm..ctor (AutoOpenMode autoOpenMode, System.String autoOpenParam) [0x00000] in <filename unknown>:0 
  at (wrapper remoting-invoke-with-check) IPLab.MainForm:.ctor (IPLab.MainForm/AutoOpenMode,string)
  at IPLab.MainForm.Main (System.String[] args) [0x00000] in <filename unknown>:0 
[ERROR] FATAL UNHANDLED EXCEPTION: System.NotSupportedException: Can't get timezone name.
  at System.CurrentSystemTimeZone..ctor (Int64 lnow) [0x00000] in <filename unknown>:0 
  at System.TimeZone.get_CurrentTimeZone () [0x00000] in <filename unknown>:0 
  at System.DateTime.get_Now () [0x00000] in <filename unknown>:0 
  at System.Windows.Forms.TextBoxBase..ctor () [0x00000] in <filename unknown>:0 
  at System.Windows.Forms.TextBox..ctor () [0x00000] in <filename unknown>:0 
  at System.Windows.Forms.ComboBox+ComboTextBox..ctor (System.Windows.Forms.ComboBox owner) [0x00000] in <filename unknown>:0 
  at (wrapper remoting-invoke-with-check) System.Windows.Forms.ComboBox/ComboTextBox:.ctor (System.Windows.Forms.ComboBox)
  at System.Windows.Forms.ComboBox.set_DropDownStyle (ComboBoxStyle value) [0x00000] in <filename unknown>:0 
  at System.Windows.Forms.ComboBox..ctor () [0x00000] in <filename unknown>:0 
  at (wrapper remoting-invoke-with-check) System.Windows.Forms.ComboBox:.ctor ()
  at IPLab.HistogramWindow.InitializeComponent () [0x00000] in <filename unknown>:0 
  at IPLab.HistogramWindow..ctor () [0x00000] in <filename unknown>:0 
  at (wrapper remoting-invoke-with-check) IPLab.HistogramWindow:.ctor ()
  at IPLab.MainForm..ctor (AutoOpenMode autoOpenMode, System.String autoOpenParam) [0x00000] in <filename unknown>:0 
  at (wrapper remoting-invoke-with-check) IPLab.MainForm:.ctor (IPLab.MainForm/AutoOpenMode,string)
  at IPLab.MainForm.Main (System.String[] args) [0x00000] in <filename unknown>:0 

Unhandled Exception:
System.NullReferenceException: Object reference not set to an instance of an object
  at System.Windows.Forms.Form.Dispose (Boolean disposing) [0x00000] in <filename unknown>:0 
  at IPLab.MainForm.Dispose (Boolean disposing) [0x00000] in <filename unknown>:0 
  at System.ComponentModel.Component.Finalize () [0x00000] in <filename unknown>:0 
[mg@MgCentOS bin]$ 

Could you please help me how I can handle this error and start Image Processing Lab application?

0

PlayOnLinux is a nice graphical frontend for wine that (for me at least) is much easier to operate.

As a test I installed Image Processing Lab 2.8.0 using the PlayOnLinux "Install a non-listed program" feature. The program installed perfectly and worked on the first try; I loaded and tweaked a few images and things seem to work well. I tested with PlayOnLinux version 4.2.9, the current version.

If you don't have PlayOnLinux, you can get the RPM at http://rpm.playonlinux.com/ or other versions at https://www.playonlinux.com/en/download.html.

At the main screen, choose Install, then Install a non-listed program option in the bottom corner.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.