0

I have installed mysql-workbench on Fedora 23 Virtual machine (VMware) using the command :

yum install mysql-workbench

Now when I tried to issue the command mysql-workbench from terminal I am getting the error :

/usr/libexec/mysql-workbench/mysql-workbench-bin: error while loading shared libraries: libzip.so.2: cannot open shared object file: No such file or directory

Also I tried to open same using the mysql icon but when I click on this it does nothing. not sure what I am missing here

  • what packages your system find if you search in your repos for : yum list mysql-workbench-community ? – lese Nov 16 '15 at 9:55
  • you need to load the right repo – unixmiah Jan 26 '16 at 18:18
  • ahh, you need to purge and reinstall. – unixmiah Jan 26 '16 at 18:18
0

As you can see on this link, there is the same problem : https://bugs.mysql.com/bug.php?id=75803

Check if you have libzip package installed on your machine. If not, install it and retry.

  • I installed both libzip and tinyxml but still no luck. I am still getting the same error message. I had issued this terminal command to install libzip yum install libzip – LilRazi Nov 21 '15 at 2:55
  • Which error message you get ? – Tata2 Nov 23 '15 at 10:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.