I am trying to load the rtl8723ae kernel module on Arch Linux.

When I run

lsmod | grep rtl8723ae

...it doesn't show anything.

When I arch-chroot into the install from an Arch install USB, it is showing the module as loaded; the same command returns the module.

If this module is supposed to come as standard with Arch, why can't I see it?


You misunderstand what the command does. lsmod doesn't list all available modules, it only lists the modules that are currently loaded. For example, on my Arch:

$ lsmod | grep rtl8723ae  ## returns nothing, the module isn't loaded
$ sudo modprobe rtl8723ae
$ lsmod | grep rtl8723ae
rtl8723ae              81920  0
btcoexist              53248  1 rtl8723ae
rtl8723_common         20480  1 rtl8723ae
rtl_pci                28672  1 rtl8723ae
rtlwifi                65536  2 rtl_pci,rtl8723ae

As you can see, the module is listed as soon as you actually load it. Presumably, something in your chrooted environment is causing it to be loaded automatically.

  • The problem I had was that I ran modprobe first, expecting it to be loaded. I didn't ask clearly enough so I have marked it as answer. – Beakie Nov 15 '15 at 23:10
  • It turned out I had a kernel version problem. My boot partition (but no /boot) had a copy of my old kernel and was loading that. This was causing my module folder to not be found. I updated these files and I got it to load the module. – Beakie Nov 15 '15 at 23:10
  • @Beakie ah, yes, that would do it. Glad you sorted it out and thanks for accepting. It helps keep the number of unanswered questions low. Fell very free to post your own answer explaining with more detail and accept that instead. – terdon Nov 15 '15 at 23:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.