6

I upgraded glibc for a reason that isn't around anymore so I want to downgrade it. The stupid thing is a lot of programs rely on glibc at the moment. I still have the 2.4 version on the system as the command below shows, but I'm not able to delete the 2.9 version.

# rpm -qa | grep  glibc
glibc-32bit-2.4-31.74.1
glibc-locale-2.4-31.74.1
glibc-locale-32bit-2.4-31.74.1
glibc-info-2.4-31.74.1
glibc-devel-2.4-31.74.1
glibc-2.9-2.9
glibc-i18ndata-2.4-31.74.1
glibc-devel-32bit-2.4-31.74.1

I've tried rpm -e glibc-2.9-2.9 but the system just tells me that a huge amount of stuff depends on glibc. So I was wondering if I can somehow set the 2.4 version to default or something similar and then remove the 2.9 version.

7
  • What's wrong with having it?
    – Maxim Yegorushkin
    Commented Oct 6, 2011 at 10:34
  • since i did the upgrade my yast doesn't work anymore. I receive this error : warning: the qt frontend is installed but does not work warning: the ncurses frontend is installed but does not work You need to install yast2-ncurses to use the YaST2 text mode interface
    – almightyBob
    Commented Oct 6, 2011 at 11:16
  • plus now i think it has something to do with this other problem i'm having stackoverflow.com/questions/7675725/…
    – almightyBob
    Commented Oct 6, 2011 at 14:25
  • you don't have glibc-2.4-2.4 installed from the list of packages you showed. If you remove the 2.9 version your system won't have a glibc library anymore, which is bad. I guess your programs are not working because you have some glibc-* package at version 2.4 and some other at version 2.9. Did you install version 2.9 from package manager or from a custom rpm?
    – pqnet
    Commented Aug 27, 2014 at 9:10
  • Right, this is tricky. After kernel glibc is probably the most important package on the system, because it creates a layer between the kernel and rest of the userland. On the top of that it contains the dynamic linker. Which means without it only statically linked application will work. Linux system is probably unusable without it. You seem to have the main subpackage glibc of different version than the rest of the subpackages. You have to either upgrade glibc or downgrade rest of the glibc* packages. Commented Oct 30, 2014 at 14:31

1 Answer 1

7

There are much simpler ways to downgrade the glibc as well. For example, yum will calculate all of the needed dependencies for you with a

yum downgrade glibc\* 

command. But beware: downgrading glibc is always a really dangerous trick, and it is so on every system.

Glibc on version 2.4 and 2.9 had already very good compatibility between them, I suggest for you the best option were is your 2.9 left.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .