1

Preseed does not seem to work for me. When executing the preseee/lat command it fails with exit 2. At this point after trying it 6 times it would be nice to get some advice.

Every time I got an exit 2.

This is the part of the preseed that fails:

d-i preseed/late_command string \
apt-install mednafen mame wget git openssh-server; \
in-target wget --no-check-certificate http://build.ppsspp.org/builds/iOS-fat/ppssppbuildbot-org.ppsspp.ppsspp-1.1.1-ios-fat.deb -O /home/arcadia/ppsspp.deb; \
in target dpkg -i /home/arcadia/ppsspp.deb; \
in-target git config http.sslVerify "false" && git clone https://github.com/Prezto/Arcadia /opt/arcadia; \
in-target echo '#!/bin/bash' > /usr/bin/arcadia; \
in-target echo '/opt/arcadia/Arcadia' > /usr/bin/arcadia; \
in-target chmod a+x /usr/bin/arcadia; \
in-target git config http.sslVerify "false" && git clone https://github.com/Prezto/Arcadia-splash /lib/plymouth/themes/arcadia-splash; \
in-target update-alternatives --install /lib/plymouth/themes/default.plymouth default.plymouth /lib/plymouth/themes/arcadia-splash/arcadia-splash.plymouth 100; \
in-target update-alternatives --set default.plymouth /lib/plymouth/themes/arcadia-splash/arcadia-splash.plymouth; \
in-target cat /etc/systemd/system/getty.target.wants/getty@tty1.service | sed -e "s/ExecStart=-\/sbin\/agetty --noclear \%I \$TERM/ExecStart=-\/sbin\/agetty --autologin     arcadia --noclear \%I \$TERM/" > /etc/systemd/system/getty.target.wants/getty@tty1.service; \
in-target mkdir -p /home/arcadia/.config/openbox; \
in-target echo 'hsetroot  /lib/plymouth/themes/arcadia-splash/arcadia.png &' > /home/arcadia/.config/openbox/autostart; \
in-target echo 'arcadia &' >> /home/arcadia/.config/openbox/autostart; \
in-target echo 'openbox-session' > /home/arcadia/.xinitrc

Does anyone see what is wrong with this? And why this would fail?

Update:

After many hours it is clear to me that it is better to copy a script to the target system and execute it there.

d-i preseed/late_command string cp -a /cdrom/preseed/post-install.sh /target/post-install.sh; in-target /bin/bash /post-install.sh
  • an error message or relevant log extract would be useful. and at what point does it fail? – cas Nov 14 '15 at 2:30
  • I just made a new iso and i am running the system again. This time without the ppspp installation lines. The previous vm was already removed so now i am trying this to get a log extraction. – Dany Nov 14 '15 at 2:44
  • i would suggest building a package for this Prezto/Arcadia program rather than using git. Then all the preseed has to do is install the package. You can do all the setup in the .postinst script AND you get to use the exact same tested version on each pre-seeded machine rather than whatever happens to be on github when you build the machine. – cas Nov 14 '15 at 3:26
  • I use this repo because i wrote the software in it and have full control. It will be easier to update when pulling from git master branch. Otherwise i have to build a package every update. This setup is also related to the update daemon which i am also making. – Dany Nov 14 '15 at 4:31
  • After all night i may have a solution.Update answer – Dany Nov 14 '15 at 7:51
2

After many hours it is clear to me that it is better to copy a script to the target system and execute it there.

d-i preseed/late_command string cp -a /cdrom/preseed/post-install.sh /target/post-install.sh; in-target /bin/bash /post-install.sh

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.