1

I am trying to install a few programs such as git / fluxgui on my Linux Mint computer. However, every time I enter the following command with my password

sudo apt-get install git

or

sudo apt-get install fluxgui

I only get this output for a few milliseconds:

Reading packages list ... 8%:

and then it disappears and I'm back in the next line of input in the console. It's almost as if I never entered the sudo apt-get install command.

To be sure, I tried the same for sudo apt-get check, and the exact same thing happened.

Does anyone know how to solve this issue?

EDIT: I have already tried running sudo apt-get update. It lists the packages that it has fetched followed by :

Fetched 3,116 kB in 6s (496 kB/s)

And then immediately after that, the same thing happens and it gives me:

Reading packages list ... 8%:

And ends again without any error statement.

2

You need to run first apt-get update

From man page:

update
           update is used to resynchronize the package index files from their sources. The indexes of available
           packages are fetched from the location(s) specified in /etc/apt/sources.list. For example, when using a
           Debian archive, this command retrieves and scans the Packages.gz files, so that information about new and
           updated packages is available. An update should always be performed before an upgrade or dist-upgrade.
           Please be aware that the overall progress meter will be incorrect as the size of the package files cannot
           be known in advance.

So, In order for APT to get package database and refresh It is recommended to do first apt-get update

  • 1
    By the way, I've started chat-room for Mint users. I hope that will be helpful for Mint users for discussion. Aware others. – Pandya Dec 5 '15 at 12:33
  • Mint is based in Debian and Ubuntu, you would have probably more people if not restricting only to mint. – Rui F Ribeiro Dec 5 '15 at 13:23
1

I managed to find a solution that fixed my problem. I added the following line to my /etc/apt/sources.list file:

deb http://security.ubuntu.com/ubuntu trusty-security main 

Somehow that file only contained another line:

deb http://cran.ma.imperial.ac.uk/bin/linux/ubuntu vivid/

which somehow wasn't working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.