1

What I have here is an NTP server (on Linux Mint) and a client (likewise). Server is configured to send a multicast message across the LAN which clients receive and update their clocks - it was designed so to reduce network load.

The NTP server is, in turn, updating its own clock from a unicast NTP server of a higher level, also in the same LAN. What does not work is the receiving the multicast packet and updating clock on the client's side.

I am currently sniffing packets on the client machine and I can see multicasts coming. Using ntpdate -s on a client machine and pointing to the higher-level NTP in the same LAN works, i.e. the clock is updated.

I'm attaching configs for both Multicast server:

http://pastebin.com/wGK8Szqj

and client:

http://pastebin.com/HU8R8L0a

Here's proof that the Mcast packets reach the client:

I already tried running ntpd client with -Ab (accepting unauthenticated broadcasts), but that does not work either.

Thanks in advance for your help.

2

Two changes are required for this to work:

  1. Remove the server definition as it's replaced by the broadcastclient entry
  2. Remove the nopeer qualifier from the restrict statement. Otherwise the client cannot (will not) talk to the multicast server.

Here's a corrected sample client configuration file:

driftfile /var/lib/ntp/ntp.drift

disable auth
broadcastclient

restrict -4  default    noquery nomodify notrap
restrict -6  default    noquery nomodify notrap
restrict     127.0.0.1
restrict     ::1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.