I have a small embedded system that I am working on that needs to be able to reduce its brightness for power saving reasons. The screen is connected by LVDS with separate Inverter Power Output connection providing the backlights power. The system is running Debian 3.2.68.

I have tried several approaches to this such as xbacklight but the folder /sys/class/backlight is empty so it fails with No outputs have backlight property. Also when I search for any other folders containing "backlight" I go almost nothing back.

$sudo find / -type d -iname \*backlight\*

When I run xrandr with no parameters to detect displays I get the following.

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x768
default connected 1024x768+0+0 0mm x 0mm
   1024x768        0.0*

I have tried updating and rebuilding my kernel as well as trying different parameters for acpi_backlight= in my menu.lst file. Any ideas on what to try from here or other ways to reduce the brightness are greatly appreciated!

Update 11/16: I have tried wiping the drive and starting over with a different distribution (Tiny Core Linux) with Xorg-7.7 in place of Xversa. The result is the same as with Debian where there is No outputs have backlight property for xbacklight. This leads me to think the issue is related to the board and its interaction with the monitor? The board is a Advantech MIO-5721 and the monitor is Mitsubishi Electric AA084XE01. They are connected by LVDS for the video and a Inverter Power Output for the backlights power.

Update 11/19: Although my final solution needs to run on Linux (probably a small version of Debian), I have installed Windows 10 as it appears more compatible with the drivers on Advantech's website. It has NOT helped solve my problem but for that reason I have re-posted it on superuser.

Update 11/23: I installed Windows 7 to test the drivers from Advantech again and I was able to adjust the brightness. Unfortunately the drivers appear to be Windows only. I am now in contact with Advantech regarding a Linux version of the drivers.

1 Answer 1


The issue was a missing driver. After being in contact with advantech they had drivers built for both 32 and 64 bit Ubuntu which were not on their website. The Ubuntu drivers (of the correct architecture) work on Debian enabling brightness control.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.