3

I have a WD My Passport USB 3.0 500 GB hard disk I have successfully installed various OSes like Ubuntu, Pinguy, Mint etc. but so far I'm unsuccessful in installing Arch Linux.

I used the net install CD and the installation is smooth, only when I reboot and boot off my hard disk I get an error saying "cannot find filep" (something along similar lines) and when I try booting again (without a reboot), I get: error 18 and and boot cylindar size exceeds maximum value type error.

I tried rootdelay=8 from the Beginners' Guide on the Arch Wiki and after scavenging through forums even enabled usb in the hook file while installing.

I still can't boot.

If it's of any further help I have dual boot Windows 7 and Ubuntu on my laptop. My usb is partitioned as following: enter image description here

here is my menu.lst http://pastebin.com/FdAiHnXZ

and the errors enter image description here enter image description here

  • Post your /boot/grub/menu.lst and including the exact errors you see when you try and boot would also be helpful. – jasonwryan Nov 9 '11 at 18:56
  • my menu.lst pastebin.com/FdAiHnXZ – kindrudekid Nov 9 '11 at 19:17
2

Grub can't read past a certain point, it looks like 8 gigs on most machines. You'll have to move the partition with your /boot to the front of the drive. I've heard (and followed) suggestions to make it a separate partition for this reason.


As for the error 15, the kernel name might be wrong, go into a recovery shell or rescue disc and check the name (usually just vmlinuz), then edit the menu.lst to match. I seem to recall an ill-advised update doing this to my arch machine once, maybe you got a similarly broken snapshot.

  • My arch box has a /boot/vmlinuz-linux file, and a symbolic link /boot/vmlinuz26 pointing to it. I run "pacman -Syu" about every week, so its relatively up-to-date. – Bruce Ediger Nov 9 '11 at 20:22
  • I don't remember when the transition happened, but machines where Grub can't read past 8GB would be getting old in the tooth and probably not running Windows 7. – Gilles Nov 9 '11 at 22:57
  • I have arch partition (with /boot) after ~80GB of unallocated space. I use GRUB 2 though. – Anton Barkovsky Nov 10 '11 at 16:55
  • still no use all names are correct. when u updare my grub on the existing ubuntu on laptop it shows up arch and boots through it effortlesslesy – kindrudekid Nov 11 '11 at 13:48
-1

Please read about the updates to the kernel package and filenames. You need to edit your menu.lst accordingly - you can do that on the fly while booting with grubs edit function).

  • its correct.. can u tmme wat to edit – kindrudekid Nov 10 '11 at 16:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.