2

From time to time, a file system check is forced when booting. This can take a long time. While I normally want these checks to happen, they can come at a bad time sometimes.

Is there anything I can do to skip an ongoing check? (It would ideally make the check the next time I boot.)

I think I remember having used a system where it said press <something> to skip, but I might be mistaken. At least on Debian I can’t spot anything like that while the check runs. Is there a key that works anyway?

Could I shutdown the PC, or would it damage something? However, it wouldn’t really help if the check starts again then.

(I know that there are solutions for skipping it for the next boot, or for selecting a different GRUB entry that doesn’t force these checks, but I’m looking for a solution that can help me when the check already started.)

4
  • You could try pressing Ctrl-C - fsck may ignore it but if it doesn't, it will exit cleanly. It is generally a bad idea to reboot or power-off fsck while it is working as it may end up corrupting the filesystem if you do that while it is writing any changes to the fs.
    – cas
    Nov 12, 2015 at 22:56
  • @cas: Thanks! In this answer, OP confirms that Ubuntu has "a user option to interrupt (and postpone) a routine disk check if it comes up during boot", so I didn’t imagine it. Now the question would be how to get this for Debian, too. -- I will try Ctrl+c the next time the check starts.
    – unor
    Nov 12, 2015 at 23:03
  • Note that on debian you can force an fsck on next boot with touch /forcefsck (or add forcefsck to the kernel command line, e.g. by pressing e to edit at the grub menu screen) - so you don't have to wait for or change the fsck mount-count.
    – cas
    Nov 12, 2015 at 23:15

1 Answer 1

2

If you have an ext3 or ext4 filesystem, then you can use this in the [options] stanza of /etc/e2fsck.conf (see man e2fsck.conf)

[options]
allow_cancellation = true
defer_check_on_battery = true

The first means

if the user interrupts e2fsck using ^C, and the filesystem is not explicitly flagged as containing errors, e2fsck will exit with an exit status of 0 instead of 32.

So the filesystem is considered mountable after the interrupt.

The second line (which is true by default, so not needed) means

the interval between filesystem checks (either based on time or number of mounts) should be doubled if the system is running on battery.

So, if you have a laptop with battery, unplug the power to avoid a periodic fsck.

Finally, if neither of these work for you, you can edit the grub menu kernel command line to add option "fastboot" to skip the fsck. This is checked for in /etc/init.d/checkroot.sh and /etc/init.d/checkfs.sh.

You can configure when periodic check are done with tune2fs on a filesystem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .