3

I've been struggling for a while trying to get a Broadcom 4306/2 working on an old Dell lap-top (Latitude D800).

My situation is very close to this one

The solution mentioned there appears to be to remove b43legacy and use b43 instead, even though the docs say pretty clearly that b43legacy is the right one. Regardless, neither one worked for me.

I have used several Arch pages as guides, even though I'm running Debian Squeeze. That's because Arch authors usually write at a lower level, so that you get a finer hold on what's wrong.

This as a sort of model of how to debug and this explaining how to set up a wireless interface.

To me, it looks like the hardware is working and the software is talking to it. See output below of wpa_supplicant. The chip sees the proper SSID of the AP, so the radio is working. It cannot associate, however.

Also shown are the output of lsmod and modinfo for b43legacy. If someone who knows how to read this stuff would help, I'd be grateful. I don't see how to go forward.

Andrew

[. . .]

Authentication with 00:26:b8:f3:f2:20 timed out.
Trying to associate with 00:26:b8:f3:f2:20 (SSID='TELUS5335' freq=2437 MHz)
Authentication with 00:26:b8:f3:f2:20 timed out.
Trying to associate with 00:26:b8:f3:f2:20 (SSID='TELUS5335' freq=2437 MHz)
Authentication with 00:26:b8:f3:f2:20 timed out.
Trying to associate with 00:26:b8:f3:f2:20 (SSID='TELUS5335' freq=2437 MHz)
Authentication with 00:26:b8:f3:f2:20 timed out.
Trying to associate with 00:26:b8:f3:f2:20 (SSID='TELUS5335' freq=2437 MHz)
Authentication with 00:26:b8:f3:f2:20 timed out.
Trying to associate with 00:26:b8:f3:f2:20 (SSID='TELUS5335' freq=2437 MHz)
Authentication with 00:26:b8:f3:f2:20 timed out.
Trying to associate with 00:26:b8:f3:f2:20 (SSID='TELUS5335' freq=2437 MHz)
Authentication with 00:26:b8:f3:f2:20 timed out.
Trying to associate with 00:26:b8:f3:f2:20 (SSID='TELUS5335' freq=2437 MHz)
Authentication with 00:26:b8:f3:f2:20 timed out.
Trying to associate with 00:26:b8:f3:f2:20 (SSID='TELUS5335' freq=2437 MHz)
Authentication with 00:26:b8:f3:f2:20 timed out.
Trying to associate with 00:26:b8:f3:f2:20 (SSID='TELUS5335' freq=2437 MHz)
Authentication with 00:26:b8:f3:f2:20 timed out.
Trying to associate with 00:26:b8:f3:f2:20 (SSID='TELUS5335' freq=2437 MHz)
Authentication with 00:26:b8:f3:f2:20 timed out.
Trying to associate with 00:26:b8:f3:f2:20 (SSID='TELUS5335' freq=2437 MHz)
Authentication with 00:26:b8:f3:f2:20 timed out.
Trying to associate with 00:26:b8:f3:f2:20 (SSID='TELUS5335' freq=2437 MHz)
Authentication with 00:26:b8:f3:f2:20 timed out.
Trying to associate with 00:26:b8:f3:f2:20 (SSID='TELUS5335' freq=2437 MHz)
Authentication with 00:26:b8:f3:f2:20 timed out.
Trying to associate with 00:26:b8:f3:f2:20 (SSID='TELUS5335' freq=2437 MHz)
Authentication with 00:26:b8:f3:f2:20 timed out.
Trying to associate with 00:26:b8:f3:f2:20 (SSID='TELUS5335' freq=2437 MHz)
Authentication with 00:26:b8:f3:f2:20 timed out.
Trying to associate with 00:26:b8:f3:f2:20 (SSID='TELUS5335' freq=2437 MHz)
Authentication with 00:26:b8:f3:f2:20 timed out.
^Z
[1]+  Stopped                 wpa_supplicant -iwlan0 -c<(wpa_passphrase "TELUS5335" "XXXXXXXXXX") -D wext
root@mothra:/var/run# kill %1

[1]+  Stopped                 wpa_supplicant -iwlan0 -c<(wpa_passphrase "TELUS5335" "XXXXXXXXXX") -D wext
root@mothra:/var/run# CTRL-EVENT-TERMINATING - signal 15 received

[1]+  Done                    wpa_supplicant -iwlan0 -c<(wpa_passphrase "TELUS5335" "XXXXXXXXXX") -D wext
root@mothra:/var/run# wpa_supplicant -iwlan0 -c<(wpa_passphrase "TELUS5335" "XXXXXXXXXX") -D nl80211 -dd
Initializing interface 'wlan0' conf '/dev/fd/63' driver 'nl80211' ctrl_interface 'N/A' bridge 'N/A'
Configuration file '/dev/fd/63' -> '/dev/fd/63'
Reading configuration file '/dev/fd/63'
Line: 1 - start of a new network block
ssid - hexdump_ascii(len=9):
     54 45 4c 55 53 35 33 33 35                        TELUS5335       
PSK - hexdump(len=32): [REMOVED]
Priority group 0
   id=0 ssid='TELUS5335'
Initializing interface (2) 'wlan0'
SIOCGIWRANGE: WE(compiled)=22 WE(source)=21 enc_capa=0xf
  capabilities: key_mgmt 0xf enc 0xf
WEXT: Operstate: linkmode=1, operstate=5
Own MAC address: 00:90:4b:7a:14:73
wpa_driver_nl80211_set_wpa
wpa_driver_nl80211_set_key: alg=0 addr=0x80b7d38 key_idx=0 set_tx=0 seq_len=0 key_len=0
nl80211: set_key failed; err=-67
wpa_driver_nl80211_set_key: alg=0 addr=0x80b7d38 key_idx=1 set_tx=0 seq_len=0 key_len=0
nl80211: set_key failed; err=-67
wpa_driver_nl80211_set_key: alg=0 addr=0x80b7d38 key_idx=2 set_tx=0 seq_len=0 key_len=0
nl80211: set_key failed; err=-67
wpa_driver_nl80211_set_key: alg=0 addr=0x80b7d38 key_idx=3 set_tx=0 seq_len=0 key_len=0
nl80211: set_key failed; err=-67
wpa_driver_nl80211_set_countermeasures
wpa_driver_nl80211_set_drop_unencrypted
RSN: flushing PMKID list in the driver
Setting scan request: 0 sec 100000 usec
WPS: UUID based on MAC address - hexdump(len=16): 5e d6 9f e5 5b d1 58 ea a1 a5 df e1 30 fe 24 25
WPS: Build Beacon and Probe Response IEs
WPS:  * Version
WPS:  * Wi-Fi Protected Setup State (0)
WPS:  * Version
WPS:  * Wi-Fi Protected Setup State (0)
WPS:  * Response Type (2)
WPS:  * UUID-E
WPS:  * Manufacturer
WPS:  * Model Name
WPS:  * Model Number
WPS:  * Serial Number
WPS:  * Primary Device Type
WPS:  * Device Name
WPS:  * Config Methods (0)
WPS:  * RF Bands (3)
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
Added interface wlan0
RTM_NEWLINK: operstate=0 ifi_flags=0x1002 ()
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
State: DISCONNECTED -> SCANNING
Starting AP scan (broadcast SSID)
Trying to get current scan results first without requesting a new scan to speed up initial association
Received scan results (0 BSSes)
Cached scan results are empty - not posting
Selecting BSS from priority group 0
Try to find WPA-enabled AP
Try to find non-WPA AP
No suitable AP found.
Setting scan request: 0 sec 0 usec
Starting AP scan (broadcast SSID)
Scan requested (ret=0) - scan timeout 10 seconds
nl80211: Event message available
nl80211: New scan results available
Received scan results (1 BSSes)
New scan results available
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
WPS: attr type=0x1049 len=6
WPS: Unsupported attribute type 0x1049 len=6
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
WPS: attr type=0x1049 len=6
WPS: Unsupported attribute type 0x1049 len=6
Selecting BSS from priority group 0
Try to find WPA-enabled AP
0: 00:26:b8:f3:f2:20 ssid='TELUS5335' wpa_ie_len=28 rsn_ie_len=24 caps=0x411
   selected based on RSN IE
   selected WPA AP 00:26:b8:f3:f2:20 ssid='TELUS5335'
Trying to associate with 00:26:b8:f3:f2:20 (SSID='TELUS5335' freq=2437 MHz)
Cancelling scan request
WPA: clearing own WPA/RSN IE
Automatic auth_alg selection: 0x1
RSN: using IEEE 802.11i/D9.0
WPA: Selected cipher suites: group 8 pairwise 24 key_mgmt 2 proto 2
WPA: set AP WPA IE - hexdump(len=30): dd 1c 00 50 f2 01 01 00 00 50 f2 02 02 00 00 50 f2 04 00 50 f2 02 01 00 00 50 f2 02 0c 00
WPA: set AP RSN IE - hexdump(len=26): 30 18 01 00 00 0f ac 02 02 00 00 0f ac 04 00 0f ac 02 01 00 00 0f ac 02 0c 00
WPA: using GTK TKIP
WPA: using PTK CCMP
WPA: using KEY_MGMT WPA-PSK
WPA: Set own WPA IE default - hexdump(len=22): 30 14 01 00 00 0f ac 02 01 00 00 0f ac 04 01 00 00 0f ac 02 00 00
No keys have been configured - skip key clearing
wpa_driver_nl80211_set_drop_unencrypted
State: SCANNING -> ASSOCIATING
wpa_driver_nl80211_set_operstate: operstate 0->0 (DORMANT)
WEXT: Operstate: linkmode=-1, operstate=5
wpa_driver_nl80211_associate
Setting authentication timeout: 10 sec 0 usec
EAPOL: External notification - EAP success=0
EAPOL: External notification - EAP fail=0
EAPOL: External notification - portControl=Auto
RSN: Ignored PMKID candidate without preauth flag
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b19 len=8
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b04 len=12
EAPOL: disable timer tick
Authentication with 00:26:b8:f3:f2:20 timed out.
Added BSSID 00:26:b8:f3:f2:20 into blacklist
No keys have been configured - skip key clearing
State: ASSOCIATING -> DISCONNECTED
wpa_driver_nl80211_set_operstate: operstate 0->0 (DORMANT)
WEXT: Operstate: linkmode=-1, operstate=5
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
EAPOL: External notification - EAP success=0
Setting scan request: 0 sec 0 usec
State: DISCONNECTED -> SCANNING
Starting AP scan (broadcast SSID)
Scan requested (ret=0) - scan timeout 30 seconds
nl80211: Event message available
nl80211: New scan results available
Received scan results (0 BSSes)
New scan results available
Selecting BSS from priority group 0
Try to find WPA-enabled AP
Try to find non-WPA AP
No APs found - clear blacklist and try again
Removed BSSID 00:26:b8:f3:f2:20 from blacklist (clear)
Selecting BSS from priority group 0
Try to find WPA-enabled AP
Try to find non-WPA AP
No suitable AP found.
Setting scan request: 5 sec 0 usec
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b19 len=8
Starting AP scan (broadcast SSID)
Scan requested (ret=0) - scan timeout 30 seconds
nl80211: Event message available
nl80211: New scan results available
Received scan results (0 BSSes)
New scan results available
Selecting BSS from priority group 0
Try to find WPA-enabled AP
Try to find non-WPA AP
No suitable AP found.
Setting scan request: 5 sec 0 usec
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b19 len=8
Starting AP scan (broadcast SSID)
Scan requested (ret=0) - scan timeout 30 seconds
nl80211: Event message available
nl80211: New scan results available
Received scan results (1 BSSes)
New scan results available
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
WPS: attr type=0x1049 len=6
WPS: Unsupported attribute type 0x1049 len=6
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
WPS: attr type=0x1049 len=6
WPS: Unsupported attribute type 0x1049 len=6
Selecting BSS from priority group 0
Try to find WPA-enabled AP
0: 00:26:b8:f3:f2:20 ssid='TELUS5335' wpa_ie_len=28 rsn_ie_len=24 caps=0x411
   selected based on RSN IE
   selected WPA AP 00:26:b8:f3:f2:20 ssid='TELUS5335'
Trying to associate with 00:26:b8:f3:f2:20 (SSID='TELUS5335' freq=2437 MHz)
Cancelling scan request
WPA: clearing own WPA/RSN IE
Automatic auth_alg selection: 0x1
RSN: using IEEE 802.11i/D9.0
WPA: Selected cipher suites: group 8 pairwise 24 key_mgmt 2 proto 2
WPA: set AP WPA IE - hexdump(len=30): dd 1c 00 50 f2 01 01 00 00 50 f2 02 02 00 00 50 f2 04 00 50 f2 02 01 00 00 50 f2 02 0c 00
WPA: set AP RSN IE - hexdump(len=26): 30 18 01 00 00 0f ac 02 02 00 00 0f ac 04 00 0f ac 02 01 00 00 0f ac 02 0c 00
WPA: using GTK TKIP
WPA: using PTK CCMP
WPA: using KEY_MGMT WPA-PSK
WPA: Set own WPA IE default - hexdump(len=22): 30 14 01 00 00 0f ac 02 01 00 00 0f ac 04 01 00 00 0f ac 02 00 00
No keys have been configured - skip key clearing
wpa_driver_nl80211_set_drop_unencrypted
State: SCANNING -> ASSOCIATING
wpa_driver_nl80211_set_operstate: operstate 0->0 (DORMANT)
WEXT: Operstate: linkmode=-1, operstate=5
wpa_driver_nl80211_associate
Setting authentication timeout: 10 sec 0 usec
EAPOL: External notification - EAP success=0
EAPOL: External notification - EAP fail=0
EAPOL: External notification - portControl=Auto
RSN: Ignored PMKID candidate without preauth flag
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b19 len=8
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b04 len=12
Authentication with 00:26:b8:f3:f2:20 timed out.
Added BSSID 00:26:b8:f3:f2:20 into blacklist
No keys have been configured - skip key clearing
State: ASSOCIATING -> DISCONNECTED
wpa_driver_nl80211_set_operstate: operstate 0->0 (DORMANT)
WEXT: Operstate: linkmode=-1, operstate=5
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
EAPOL: External notification - EAP success=0
Setting scan request: 0 sec 0 usec
State: DISCONNECTED -> SCANNING
Starting AP scan (broadcast SSID)
Scan requested (ret=0) - scan timeout 30 seconds
nl80211: Event message available
nl80211: New scan results available
Received scan results (0 BSSes)
New scan results available
Selecting BSS from priority group 0
Try to find WPA-enabled AP
Try to find non-WPA AP
No APs found - clear blacklist and try again
Removed BSSID 00:26:b8:f3:f2:20 from blacklist (clear)
Selecting BSS from priority group 0
Try to find WPA-enabled AP
Try to find non-WPA AP
No suitable AP found.
Setting scan request: 5 sec 0 usec
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b19 len=8
Starting AP scan (broadcast SSID)
Scan requested (ret=0) - scan timeout 30 seconds
nl80211: Event message available
nl80211: New scan results available
Received scan results (0 BSSes)
New scan results available
Selecting BSS from priority group 0
Try to find WPA-enabled AP
Try to find non-WPA AP
No suitable AP found.
Setting scan request: 5 sec 0 usec
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b19 len=8
Starting AP scan (broadcast SSID)
Scan requested (ret=0) - scan timeout 30 seconds
nl80211: Event message available
nl80211: New scan results available
Received scan results (1 BSSes)
New scan results available
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
WPS: attr type=0x1049 len=6
WPS: Unsupported attribute type 0x1049 len=6
WPS: attr type=0x104a len=1
WPS: attr type=0x1044 len=1
WPS: attr type=0x1049 len=6
WPS: Unsupported attribute type 0x1049 len=6
Selecting BSS from priority group 0
Try to find WPA-enabled AP
0: 00:26:b8:f3:f2:20 ssid='TELUS5335' wpa_ie_len=28 rsn_ie_len=24 caps=0x411
   selected based on RSN IE
   selected WPA AP 00:26:b8:f3:f2:20 ssid='TELUS5335'
Trying to associate with 00:26:b8:f3:f2:20 (SSID='TELUS5335' freq=2437 MHz)
Cancelling scan request
WPA: clearing own WPA/RSN IE
Automatic auth_alg selection: 0x1
RSN: using IEEE 802.11i/D9.0
WPA: Selected cipher suites: group 8 pairwise 24 key_mgmt 2 proto 2
WPA: set AP WPA IE - hexdump(len=30): dd 1c 00 50 f2 01 01 00 00 50 f2 02 02 00 00 50 f2 04 00 50 f2 02 01 00 00 50 f2 02 0c 00
WPA: set AP RSN IE - hexdump(len=26): 30 18 01 00 00 0f ac 02 02 00 00 0f ac 04 00 0f ac 02 01 00 00 0f ac 02 0c 00
WPA: using GTK TKIP
WPA: using PTK CCMP
WPA: using KEY_MGMT WPA-PSK
WPA: Set own WPA IE default - hexdump(len=22): 30 14 01 00 00 0f ac 02 01 00 00 0f ac 04 01 00 00 0f ac 02 00 00
No keys have been configured - skip key clearing
wpa_driver_nl80211_set_drop_unencrypted
State: SCANNING -> ASSOCIATING
wpa_driver_nl80211_set_operstate: operstate 0->0 (DORMANT)
WEXT: Operstate: linkmode=-1, operstate=5
wpa_driver_nl80211_associate
Setting authentication timeout: 10 sec 0 usec
EAPOL: External notification - EAP success=0
EAPOL: External notification - EAP fail=0
EAPOL: External notification - portControl=Auto
RSN: Ignored PMKID candidate without preauth flag
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b19 len=8
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Wireless event: cmd=0x8b04 len=12
^Z
[1]+  Stopped                 wpa_supplicant -iwlan0 -c<(wpa_passphrase "TELUS5335" "XXXXXXXXXX") -D nl80211 -dd

Here is lsmod and modinfo:

Module                  Size  Used by
nls_utf8                 908  1 
nls_cp437               4489  1 
vfat                    6562  1 
fat                    34824  1 vfat
usb_storage            31009  1 
ppdev                   4058  0 
lp                      5570  0 
firewire_sbp2           9603  0 
arc4                     974  2 
ecb                     1405  2 
b43legacy              91692  0 
ch7006                 13868  1 
snd_intel8x0m           8100  0 
snd_intel8x0           19595  1 
snd_ac97_codec         79152  2 snd_intel8x0m,snd_intel8x0
nouveau               314668  2 
mac80211              123126  1 b43legacy
ac97_bus                 710  1 snd_ac97_codec
ttm                    33242  1 nouveau
cfg80211               87209  2 b43legacy,mac80211
drm_kms_helper         18545  2 ch7006,nouveau
rfkill                 10220  1 cfg80211
joydev                  6739  0 
snd_pcm                47226  3 snd_intel8x0m,snd_intel8x0,snd_ac97_codec
drm                   112489  5 ch7006,nouveau,ttm,drm_kms_helper
i2c_algo_bit            3493  1 nouveau
yenta_socket           16403  2 
rsrc_nonstatic          7057  1 yenta_socket
i2c_core               12763  5 ch7006,nouveau,drm_kms_helper,drm,i2c_algo_bit
snd_seq                35375  0 
snd_seq_device          3673  1 snd_seq
snd_timer              12270  2 snd_pcm,snd_seq
video                  14605  0 
dcdbas                  3872  0 
led_class               1757  1 b43legacy
rng_core                2178  1 b43legacy
shpchp                 21200  0 
parport_pc             15799  1 
pci_hotplug            18545  1 shpchp
parport                22554  3 ppdev,lp,parport_pc
output                  1204  1 video
snd                    34399  9 snd_intel8x0m,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_seq,snd_seq_device,snd_timer
evdev                   5609  13 
pcspkr                  1207  0 
psmouse                44817  0 
soundcore               3450  1 snd
ac                      1636  0 
battery                 3782  0 
button                  3598  1 nouveau
processor              26283  1 
snd_page_alloc          5001  3 snd_intel8x0m,snd_intel8x0,snd_pcm
serio_raw               2916  0 
usbhid                 27928  0 
hid                    51509  1 usbhid
ext4                  256629  1 
mbcache                 3762  1 ext4
jbd2                   56091  1 ext4
crc16                   1027  1 ext4
sg                     19917  0 
sr_mod                 10770  0 
sd_mod                 25969  4 
crc_t10dif              1012  1 sd_mod
cdrom                  26435  1 sr_mod
ata_generic             2247  0 
ssb                    33626  1 b43legacy
mmc_core               38421  1 ssb
ata_piix               17716  1 
uhci_hcd               16013  0 
thermal                 9206  0 
firewire_ohci          16705  0 
pcmcia                 16194  1 ssb
tg3                    95797  0 
libata                115713  2 ata_generic,ata_piix
ehci_hcd               28533  0 
usbcore                99350  5 usb_storage,usbhid,uhci_hcd,ehci_hcd
thermal_sys             9378  3 video,processor,thermal
firewire_core          31155  2 firewire_sbp2,firewire_ohci
crc_itu_t               1035  1 firewire_core
pcmcia_core            20426  4 yenta_socket,rsrc_nonstatic,ssb,pcmcia
libphy                 11618  1 tg3
scsi_mod              104949  6 usb_storage,firewire_sbp2,sg,sr_mod,sd_mod,libata
nls_base                4727  5 nls_utf8,nls_cp437,vfat,fat,usbcore

filename:       /lib/modules/2.6.32-5-686/kernel/drivers/net/wireless/b43legacy/b43legacy.ko
firmware:       FW10
license:        GPL
author:         Michael Buesch
author:         Stefano Brivio
author:         Martin Langer
description:    Broadcom B43legacy wireless driver
alias:          ssb:v4243id0812rev04*
alias:          ssb:v4243id0812rev02*
depends:        mac80211,ssb,led-class,cfg80211,rng-core
vermagic:       2.6.32-5-686 SMP mod_unload modversions 686 
parm:           pio:enable(1) / disable(0) PIO mode (int)
parm:           bad_frames_preempt:enable(1) / disable(0) Bad Frames Preemption (int)
parm:           fwpostfix:Postfix for the firmware files to load. (string)
1

I have now gotten it to work. The problem was very low antenna gain. By moving it away from nearby metal objects and holding it sideways, up-side down, etc. it was possible to make it associate and work normally. A very physical solution to a technical problem. I guess anything below -80 dB should be suspect.

  • Never thought about trying Arch on that, could indeed solve the problem if the driver is the problem. Recompiling a kernel and/or drivers is not the problem, although I should weigh time spent on this. Thanks (BTW we should remove these comments as they have nothing to do with the original Q&A). – Anthon Feb 7 '16 at 6:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.