1

I have 2 laptops with Nvidia optimus GPUs, both running Ubuntu werewolf.

I installed bumblebee and nvidia-355 from the graphics-drivers ppa. This seems to work ok. Except that after a reboot, xorg no longer starts.

The error in the Xorg.0.log says:

[    22.867] Data incomplete in file /etc/X11/xorg.conf
        Undefined Screen "nvidia" referenced by ServerLayout "layout".
[    22.867] (EE) Problem parsing the config file
[    22.867] (EE) Error parsing the config file
[    22.867] (EE) 
Fatal server error:
[    22.867] (EE) no screens found(EE) 

and in /etc/X11/xorg.conf it says:

Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia"
    Inactive "intel"
EndSection

Section "Device"
    Identifier "intel"
    Driver "modesetting"
    BusID "PCI:0@0:2:0"
    Option "AccelMethod" "None"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection

Apparently this xorg.conf file is broken, because of 'Screen 0 "nvidia"' not really existing.

The bizarre thing is that even after purging the ppa, and purging all the bumblebee packages, this xorg.conf file keeps reappearing. I copied a old version of one of the backup files to xorg.conf, and after rebooting the same broken xorg.conf file reappears. Where does it come from? How can i get a working xorg.conf file and stop the broken one from reappearing?

I've even tried installing and purging the bumblebee packages from the standard repositories (not ppa) and still the broken xorg.conf file keeps reappearing.

So basically I would like to either successfully install bumblebee such that the machine boots, xorg starts, and optirun can be used...

or

I would like to successfully uninstall bumblebee so that the machine boots, xorg starts, and i can use x-windows without optirun.

So far I can't successfully install or uninstall bumblebee, leaving the system with no x-windows available.

I've already reinstalled ubuntu two or three times to repair this exact problem, but since it is clearly a configuration problem, this is massive overkill and I don't want to do it again. I want to fix the configuration.

1

After you uninstall nvidia drivers and the related stuff like bumblebee, reverting to Intel should be straightforward:

$ cd /etc/X11/
$ su -  

# Xorg -configure

What does it say?

  • I'm having the same issue. It says (EE) Fatal server error: (EE) Server is already active for display 0. If the server is no longer running, remove /tmp/.X0-lock and start again. (EE)(EE) Please consult The X.Org Foundation support at wiki.x.org for help. (EE) – Gonzalo Dec 22 '15 at 21:44
  • Posted a possible solution that worked for me. – Gonzalo Dec 22 '15 at 21:56
0

Executing this solved my problem

sudo apt-get install --reinstall xserver-xorg-video-nouveau
0

Had the same problem on Wily, found this post while searching for a known solution.

The problem is that a new service, gpu-manager (no idea what it does or why), is screwing up with the alternatives. Blacklisting it and reinstalling bumblebee so that update-alternatives is fixed solves the problem, no more black screens and optirun working as intended.

Make sure there's no broken /etc/X11/xorg.conf left behind, run the following and reboot:

sudo systemctl mask gpu-manager.service
sudo apt-get install --reinstall bumblebee bumblebee-nvidia

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.