0

After updating from Fedora 22 to Fedora 23, I'm having trouble compiling anything with biblatex (biber as backend). Anything without biblatex compiles just fine, so I'm assuming it's something with the biber package for Fedora 23. Here's the error message:

Process started

Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/\\ding{ <-- HERE ([2-9AF][0-9A-F])}/ at /usr/share/perl5/Biber/LaTeX/Recode.pm line 207.

Process exited with error(s)

Is this something where I just have to wait until the code is updated, or can I do a workaround (not involving reverting the operating system to F22, of course, which worked just fine).

Someone else had a similar error here (perl - automake error), but I'm unsure how to fix this myself.

  • Alter that } in the regex to be escaped, \} – thrig Nov 10 '15 at 21:30
  • As I thought, but doing so then gives me the following error: Backslash found where operator expected at /usr/share/perl5/Biber/LaTeX/Recode.pm line 207, near "$1\" (Missing operator before \?) – Richard Nov 10 '15 at 21:39
  • Where did $1 come from? That's not in your post. Could you post the full code somewhere? That module doesn't appear to be on CPAN... – thrig Nov 10 '15 at 21:43
  • Actually, I managed to fix it; I'll post an answer soon. – Richard Nov 10 '15 at 21:46
0

It actually ended up being two answers.

Warning: I'm relatively new to Linux, and I'm not a developer/coder of any kind. This will probably seem like child's play, in which case it's free to be deleted.

  1. I fixed the error in the original file, fixing { to \{ (@thrig had a slight error in his comment to the main post, which led me to making that same error before fixing it as shown here).
  2. Doing so then pointed towards another file at /usr/share/perl5/Biber/Input/file/bibtex.pm with a similar error. Fixing this error then allows me to compile everything just fine.

What's confusing me still, however, is why it signalled these particular left braces; there are countless left braces in these files that aren't escaped, but I'm assuming that type of detail is above my head.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.