1

I can access to my specific folder like this:

ssh -YX  xxx@xxxxxx.xxx.xxxx.xx
cd ../the/folder/I/want   

or with an absolute path

ssh -YX  xxx@xxxxxx.xxx.xxxx.xx
cd /the/absolute/path/to/the/folder/I/want

However I can't lsit from my distant home directory

ssh -YX  xxx@xxxxxx.xxx.xxxx.xx
ls ../the/folder/I/want 
-> ls: cannot access ../the/folder/I/want: No such file or directory

I can mount and access to my home folder with sshfs. However, if I try to mount the specific folder with sshfs, for instance:

sshfs xxx@xxxxxx.xxx.xxxx.xx:/the/absolute/path/to/the/folder/I/want   ~/mountpoint

I can see the mounted folder, but I have no permissions to access it. This is the result of ls -l local command:

d---rwx--- 1 root wheel 4,0K 4 nov 22:46 mountpoint

Is there a way to mount this specific folder?

  • sudo sshfs -o allow_other xxx@xxxxxx.xxx.xxxx.xx:/the/absolute/path/to/the/folder/I/want ~/mountpoint doesn't wotk either – sandoval31 Nov 10 '15 at 14:53
1

This happens when there are folders that only give access to specific groups. Then sshfs can fail to see that one of the IDs in that group belongs to the user that mounted the drive.

You just have to add the option "-o defer_permissions", e.g.

sshfs -o defer_permissions xxx@xxxxxx.xxx.xxxx.xx:/the/absolute/path/to/the/folder/I/want   ~/mountpoint

More information can be found here: https://github.com/osxfuse/osxfuse/wiki/Mount-options#default_permissions-and-defer_permissions?

0

It was a problem of permission. The issue was finally resolved when the administrator gave me all permission on the distant folder.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.