1

Until recently, kde was autommounting all my partitions after I was logging in.

But, after an upgrade (a few months ago), this stopped happening and now I use krusader to manually mount the patitions (I access each one of them and they get mounted).

I'm tired of doing this and I was wondering if someone knows what happened and if there is a fix for this.

0

So, it wasn't that hard after all.

I found this solution that worked perfectly: https://www.kubuntuforums.net/showthread.php?68092-Secondary-hard-drive-won-t-auto-mount&p=371603&viewfull=1#post371603.

TLDR version:

  • Change the /usr/share/kde4/services/kded/device_automounter.desktop line X-KDE-Kded-phase=1 to X-KDE-Kded-phase=0
  • Open "kcmshell4 kcmkded" and start 'Removable Device Automounter'
  • Open "kcmshell4 device_automounter_kcm" and pick the right options from the KDE 'Removable Devices module'
0

I do not know where the error is comming from, but you can always add a line to your /etc/fstab to solve it :)

UUID={partition UUID} {partition mount_point}  {partition type}    {options}  0       1

As an example, my main partition is mounted with these parameters:

UUID=a1e37f31-800a-481b-b039-d79087a2ffed  /  ext4 errors=remount-ro 0       1
  • I don't want to take care of fstab. I'm trying to find a solution that will do it automatically. – cristi Nov 9 '15 at 16:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.