10

I installed iptraf on CentOS 7 to monitor the network:

[root@test ~]# yum install iptraf
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: ftp.osuosl.org
 * extras: mirrors.usinternet.com
 * updates: mirror.tzulo.com
Package iptraf-ng-1.1.4-4.el7.x86_64 already installed and latest version
Nothing to do
[root@test ~]# iptraf
bash: iptraf: command not found

Is this a new bug?!

3 Answers 3

9

I encountered a similar problem with Ubuntu 18.04.

Just run iptraf-ng instead of iptraf.

1
  • how stupid is this? Sep 26, 2022 at 11:08
5

Your CentOS automatically decided to install iptraf-ng instead. The binary of the iptraf-ng package is iptraf-ng. Next time just use rpm -ql iptraf-ng to list the package contents.

1
  • That's not it. I had the same issue with apt, and after checking I have both iptraf and iptraf-ng. When I got the command not found error, I thought I'd forgotten to install it, so I ran the install command again. I found out not only that it was already installed, but it even gave the version, which is different from the iptraf-ng version installed on my machine.
    – Nate T
    Jul 11, 2021 at 13:23
0

I encounter the same problem when I tried to install iptraf.

I was following the instructions from here where it states the package to be installed is iptraf. On the other hand after some research I found out that iptraf is now actually

a transitional dummy package to help iptraf users to upgrade to iptraf-ng, you may remove it safely

from here. So, the conclusion is:

a) that you possibly have iptraf-ng in your machine already and if not install this one and not the transitional dummy one (iptraf that is).
b) you can safely remove the dummy package without affecting the real package functionality.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .