2

I run both Arch Linux and Windows 10 on my computer. When I cd onto the Windows partition (which uses NTFS), I notice that all files and folders have 777 file permissions. I want to run
$ chmod 640 -R * from the partition's root directory to set all file and folder permissions to what they are normally on my linux partition, but I'm a little afraid it might mess up Windows. Is it safe to run this command? Same applies to my external USB hard drive.

1 Answer 1

1

"Permissions" on NTFS file-systems are a mount option. NTFS doesn't support unix style permissions, ntfs-3g has to fake it with NTFS ACLs.

Use umask=027 on the mount command line (or in /etc/fstab) to get permissions of 640.

See man mount.ntfs for more details and options.

6
  • No, that is not true. NTFS does support file permissions. I just tested it.
    – Rapti
    Nov 8, 2015 at 2:33
  • ntfs-3g fakes unix perms on NTFS. read the man page. see also tuxera.com/community/ntfs-3g-advanced/ownership-and-permissions
    – cas
    Nov 8, 2015 at 2:38
  • Oh, that explains why it worked. So, if permissions are not acually set, is it correct to assume that windows doesn't even know about them and thus it is safe to chance permissions?
    – Rapti
    Nov 8, 2015 at 2:45
  • personally, i'd use the umask etc mount-time options and only run chmod on files and dirs that need to be different from the default. as the doc i linked to mentions, faking chmod/chown involves lots of ACLs per file. that's got to slow down filesystem access if every file and dir has its own individual set of ACLs that need to be interpreted.
    – cas
    Nov 8, 2015 at 2:48
  • 1
    that's what the umask mount option is for. umask=027 will result in 640 for files and 750 for directories.
    – cas
    Nov 8, 2015 at 3:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .