0

I'm running Linux Mint 17.2 and Windows 7. Today I was getting an error message when booting into Win: "BootMgr missing." I ran the common system repair tasks available on the Windows installation media. This seemed to have fixed it. But then Mint was gone from grub menu. So I booted from a live media of that and installed and ran boot-repair. It says everything went fine — and, from what I can tell from this log, it found Windows — but in the grub menu I only get Mint.

Any suggestions?

http://paste2.org/D7ZLb8A1

When running "update-grub", I get

Generating grub configuration file ...
Found linux image: /boot/vmlinuz-3.16.0-38-generic
Found initrd image: /boot/initrd.img-3.16.0-38-generic
Found linux image: /boot/vmlinuz-3.13.0-67-generic
Found initrd image: /boot/initrd.img-3.13.0-67-generic
  No volume groups found
done
0

After managing to boot into windows via the USB installer containing WIndows, I ran bcdedit and noticed that it was using the USB's Bootmgr file to boot the local installation of Windows. I copied it to C:\, ran update-grub and now it's working.

No idea how bootmgr disappeared in the first place

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.