1

I have a relatively new build that I can't seem to get audio to work on.

I have one card that i can see with pacmd list-cards:

1 card(s) available.
    index: 0
        name: <alsa_card.pci-0000_00_1f.3>
        driver: <module-alsa-card.c>

It lists a couple sinks:

    sinks:
    alsa_output.pci-0000_00_1f.3.analog-stereo/#0: Built-in Audio Analog Stereo
    alsa_output.pci-0000_00_1f.3.iec958-stereo/#4: Built-in Audio Digital Stereo (IEC958)

And can see that my headphones are connected:

ports:
    analog-input-front-mic: Front Microphone (priority 8500, latency offset 0 usec, available: no)
        properties:
            device.icon_name = "audio-input-microphone"
    analog-input-rear-mic: Rear Microphone (priority 8200, latency offset 0 usec, available: no)
        properties:
            device.icon_name = "audio-input-microphone"
    analog-input-linein: Line In (priority 8100, latency offset 0 usec, available: no)
        properties:

    analog-output-lineout: Line Out (priority 9900, latency offset 0 usec, available: no)
        properties:

    analog-output-headphones: Headphones (priority 9000, latency offset 0 usec, available: yes)
        properties:
            device.icon_name = "audio-headphones"
    iec958-stereo-output: Digital Output (S/PDIF) (priority 0, latency offset 0 usec, available: unknown)
        properties:

My problem is that any program that uses the analog-stereo output (from youtube to RhythmBox) blocks if i have it output audio to analog-stereo. I get no sounds and the program won't even run. If i switch the application to use iec958-stereo it will run and i can see the volume bars move in pavucontrol but since the only port for that output is S/PDIF I don't hear anything with my headphones.

EDIT:

I turned off pulse as described below. I then used alsamixer to turn all the channels up. I can hear white noise through the headphones which gets much quieter if I mute the front and rear mics. However, still no sound from the applications (though they don't block). In case it matters I have a Realtek ALC1150 chip.

EDIT2:

Since it really seems like a driver issue and who knows how long that will take to get worked out, I picked up one of these for ~$35. Dropped it in and it worked first boot.

1 Answer 1

1

You could try to check if the problem is with PulseAudio or not, by disabling it temporarily in configs and instead enabling Alsa's mixer thingie.

  1. Disable PulseAudio:

    echo autospawn=no > ~/.pulse/client.conf
    pulseaudio -k
    
  2. Enable dmix, Alsa's native mixer:

    sudo gedit ~/.asoundrc
    

    to open the .asoundrc config file, and then paste:

    pcm.!default {
        type plug
        slave.pcm "dmixer"
    }
    
    pcm.dmixer  {
        type dmix
        ipc_key 1024
        slave {
        pcm "hw:1,0"
        period_time 0
        period_size 1024
        buffer_size 4096
        rate 44100
    }
    bindings {
        0 0
        1 1
    }
    }
    
    ctl.dmixer {
    type hw
    card 0
    }
    

    reboot your computer and see if sound works. If it works, it's a problem with PulseAudio, if it doesn't (even with for example Youtube, or with VLC player when tried with all sound output options), it's most likely a driver or hardware problem. If it works and you can't figure out what was wrong with PA, you may want to keep it like that, I used that setting (slightly modified) for over a year and the only program I tried that has problems with it is Skype.

To reverse the effects simply delete the ~/.pulse/client.conf and ~/.asoundrc files and reboot.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .