2


I facing difficulties to mount a remote directory on my Debian machine: I tired to use both NFS and CIFS (Samba). For both methods, I am able to mount the directory and it functions adequately for 5-30min but then fails.

when running ls on the mount point of the local machine I get:
- when mounted with CIFS ls: reading directory .: Resource temporarily unavailable
- when mounted with NFS ls: cannot access /mnt/NAS: Stale file handle

Here is my /etc/fstab:
192.168.1.11:/NAS/music /mnt/NAS nfs defaults 0 0
//192.168.1.11/NAS/music /mnt/NAS cifs username=pi,password=samba 0 0
(I, of course, only mount one line or the other)

For both lines, I am able to mount automatically and manually and access the local mount of the remote directory for a few minutes. But it fails shortly after.

The network structure has the remote machine wired to the router while the local machine is on wifi.

Can you help me fix this ?

Thanks, Fabien

1

mount a network share through a wifi connection is not an optimal solution, given the very nature of the connection.

The problem could stem from the fact that the wifi is not stable.

You can try to mount the NFS share with the parameters

rsize=32768,wsize=32768 

and / or try to use TCP instead of UDP. The latter solution could be more costly in terms of performance, however, it should ensure a better stability to the connection.

  • Thanks. I'll try that tonight. Can you explain how the rsize and wsize helps maintain the mount ? – Fabien Nov 6 '15 at 10:52
  • IMHO these parameters should optimize the transmission by minimizing the risk of timeouts and retransmissions. At least this is the conclusion I've reached in my experiments on nfs share over wifi – LilloX Nov 6 '15 at 11:06
  • I tried ... no improvement. The NAS is stable for a little while then the link fails. This time it actually resulted into a system fialure and I had to brn a new image on the flash. ... so, I guess I will just give up on the NAS over WIFI unless anyone has further suggestions – Fabien Nov 9 '15 at 16:55
0

It might be necessary to use the "nounix" option as a parameter to mount to get rid of this annoying message/problem. For example: "mount -o uid=1000,gid=1000,rw,user=,password=,vers=1.0,nounix //bla/bla /media/bla"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.