I have a peculiar problem with my Debian Wheezy install, that is I am unable to suspend correctly. Upon suspending, my system makes a full shutdown and boots to the BIOS, the grub, and I need to login again.

I have found some blog posts and questions about suspend not working for some people, have tried modifying a few suspend scripts with no avail. Unfortunately, I can't recall what I read since I made 10-15 google searches about a week ago, but I can find them if needed.

It's a second fresh install off of a clean ISO image, after I corrupted the kernel on my last install trying to clean off Java. I'm not exactly an expert at debugging these kinds of things, so I can't really provide any details about it, other than some system info:

Release 7.8 (wheezy) 64-bit
Kernel Linux 3.2.0-4-amd64
GNOME 3.4.2


why does suspend put my system into shutdown? How can I fix it?

If you need any debug/additional info, please comment.

EDIT Additional info as requested by Gilles:

Initiating suspend: Via power button, which suspends by default in my experience, using the shutdown dialog and selecting suspend, and finally using sudo pm-suspend.

Files changed: It turns out I removed my changes upon finding out they didn't work. I can give a list of sites that I visited during the time that I tried to fix it:

Again, no changes as of the current moment.

BIOS version: I have an MSI Z77A-G43A, the BIOS screen states that it is E7758IMS V2.5, released on August 31, 2012.


  • CPU: i3-3240 @ 3.40 GHz (quad core)
  • Mobo: (see BIOS version)
  • RAM: Corsair 16GB DDR3-1333 XMS 8x2
  • HDD: Not quite sure, I currently don't have the time to open my computer to check
  • GPU: MSI nVidia GTX 970 Gaming
  • OS: (see above)

Everything else seems to be irrelevant to the issue, but if you need the HDD or more info, again, ask in the comments.

closed as unclear what you're asking by G-Man, roaima, mdpc, vonbrand, cuonglm Nov 8 '15 at 4:41

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    How do you initiate the suspend? And you DO need to tell us exactly what system files you changed, otherwise we're on a wild goose chase. Also tell us exactly what hardware you have, and the BIOS revision. – Gilles Nov 6 '15 at 22:48
  • @Gilles updated OP – xTrollxDudex Nov 7 '15 at 1:32

Classic suspend should work when you have swap partition active and by appending "resume=/dev/sda2" to your kernel command line, where /dev/sda2 should be replaced by path of your swap partition. Then, suspending is usually done:

echo shutdown >/sys/power/disk
echo disk >/sys/power/state

executed as root (should be executed from script).

However in "modern" distros this is not a way of doing things, so you'll end up with debugging your pm tools or something like that. Pressing power button usually runs script that do "classic" suspend, or runs pm tools your OS provides.

Please try classic way of suspending first.

  • The problem seemed to have fixed itself, thanks for the answer though. +1 – xTrollxDudex Nov 7 '15 at 17:49
  • Was your problem solved or it still persists? How it fixed itself? Just it did not worked, and sudden - started again to work without/prior any attempts to discover the issue? – user140866 Nov 8 '15 at 16:01
  • I'm unsure what I did, but it now works apparently. I just pressed the suspend button by mistake and the next day, it boots up into the login screen, just like its supposed to. – xTrollxDudex Nov 8 '15 at 18:12
  • OK, nice to hear. If you'll experience same symptoms in future, remember how to test properly. – user140866 Nov 8 '15 at 18:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.