0

I'm installing Drupal 8 on my Centos 6 server. To do this I needed to upgrade both PHP and MySQL. However, I'm now getting the following error message:

The libmysqlclient driver version 5.1.54 is less than the minimum required version. Upgrade to libmysqlclient version 5.5.3 or up, or alternatively switch mysql drivers to MySQLnd version 5.0.9 or up.

How to upgrade the version of libmysqlclient as required?

0

In case anyone has the same problem, here's the solution I found.

The drupal-mysql package seems to use the 5.1 library, and I can't find any to override this.

However, switching to the drupal-mysqlnd package seems to resolve this.

In my case, the install command was:

yum install php56w-mysqlnd

Hope someone finds this useful.

James

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.