2

I am trying to create a users quota in RHEL-7 with xfs file system. But I am not able do it. The procedure that I followed is as below :-

1) edit /etc/fstab/

/dev/mapper/rhel-root / xfs defaults,usrquota,grpquota 0 0 UUID=58c22d1f-85ca-4fb9-8d40-4cfbaaf0d7ca /boot xfs defaults 0 0

2) Then mount -vo remount /

mount: /dev/mapper/rhel-root mounted on /.

3) reboot too

and then checked if quota feature is enabled or not , and fount it is not enabled.

 # mount | grep 'root'

/dev/mapper/rhel-root on / type xfs (rw,relatime,seclabel,attr2,inode64,noquota)

Can you tell me its cause and how to resolve it.

1

xfs file system manages quota differently from other fs. And you need to activate flag rootflags=quota in the /etc/default/grub.

In detail: edit /etc/default/grub, adding or editing the value

GRUB_CMDLINE_LINUX="rootflags=quota"

run update-grub and performs reboot. Quota should be activated. This process may be slightly different depending on the distro.

  • you can also read man xfs-quota – LilloX Nov 4 '15 at 8:24
  • Is there any way I can do changes without reboot , as per your instruction it require reboot as I am doing changes in grub file. – decimal Nov 4 '15 at 9:10
  • No, you have to reboot. I think is the only way... – LilloX Nov 4 '15 at 9:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.