0

I am having trouble getting pidgin to build from source. Running the ./autogen.sh

I fail on not finding FARSTREAM but I have that package installed.

blubee@naibed:~/Development/pidgin-main$ sudo aptitude search farstream
i A gir1.2-farstream-0.1                                                    - Audio/Video communications framework: GObject-Introspection                      
i A gir1.2-farstream-0.2                                                    - Audio/Video communications framework: GObject-Introspection                      
i A libfarstream-0.1-0                                                      - Audio/Video communications framework: core library                               
p   libfarstream-0.1-dbg                                                    - Audio/Video communications framework: debugging symbols                          
i   libfarstream-0.1-dev                                                    - Audio/Video communications framework: development files                          
p   libfarstream-0.1-doc                                                    - Audio/Video communications framework: documentation                              
i A libfarstream-0.2-2                                                      - Audio/Video communications framework: core library                               
p   libfarstream-0.2-dbg                                                    - Audio/Video communications framework: debugging symbols                          
i   libfarstream-0.2-dev                                                    - Audio/Video communications framework: development files                          
p   libfarstream-0.2-doc                                                    - Audio/Video communications framework: documentation                              
i   libtelepathy-farstream-dev                                              - Glue library between telepathy and farstream (development files)                 
p   libtelepathy-farstream-doc                                              - Glue library between telepathy and farstream (documentation)                     
i A libtelepathy-farstream3                                                 - Glue library between telepathy and farstream                                     
p   libtelepathy-farstream3-dbg                                             - Glue library between telepathy and farstream (debug symbols)                     
p   libtelepathy-qt4-farstream2                                             - Telepathy/Farsight integration - Qt 4 library                                    
p   python-farstream                                                        - Audio/Video communications framework: Python bindings                            
v   python2.7-farstream                                                     -                              

as you can see from my aptitude search i've installed everything debian recommends for farstream but I still get the build error.

checking for JSON... yes
checking for ZLIB... yes
checking for gconftool-2... /usr/bin/gconftool-2
Using config source xml:merged:/etc/gconf/gconf.xml.defaults for schema installation
Using $(sysconfdir)/gconf/schemas as install directory for schema files
checking for GSTREAMER... yes
checking for GSTVIDEO... yes
checking for FARSTREAM... no
configure: error: 
Dependencies for voice/video were not met.
Install the necessary gstreamer and farstream packages first.
Or use --disable-vv if you do not need voice/video support.

also I have already installed all the gstreamer plugins

i   gstreamer1.0-plugins-bad                                                - GStreamer plugins from the "bad" set                                             
i   gstreamer1.0-plugins-bad-dbg                                            - GStreamer plugins from the "bad" set (debug symbols)                             
i   gstreamer1.0-plugins-bad-doc                                            - GStreamer documentation for plugins from the "bad" set                           
i   gstreamer1.0-plugins-base                                               - GStreamer plugins from the "base" set                                            
i   gstreamer1.0-plugins-base-apps                                          - GStreamer helper programs from the "base" set                                    
i   gstreamer1.0-plugins-base-dbg                                           - GStreamer plugins from the "base" set                                            
i   gstreamer1.0-plugins-base-doc                                           - GStreamer documentation for plugins from the "base" set                          
i   gstreamer1.0-plugins-good                                               - GStreamer plugins from the "good" set                                            
i   gstreamer1.0-plugins-good-dbg                                           - GStreamer plugins from the "good" set                                            
i   gstreamer1.0-plugins-good-doc                                           - GStreamer documentation for plugins from the "good" set                          
i   gstreamer1.0-plugins-ugly                                               - GStreamer plugins from the "ugly" set                                            
i   gstreamer1.0-plugins-ugly-dbg                                           - GStreamer plugins from the "ugly" set (debug symbols)                            
i   gstreamer1.0-plugins-ugly-doc                                           - GStreamer documentation for plugins from the "ugly" set    

I've been doing apt-cache and aptitude search but can't figure out what's missing. What am I missing?

-2

pidgin 2.10.11-1 is packaged for debian already (for wheezy, jessie, testing, and sid. 2.7.3 is in squeeze, and 2.10.10 is in squeeze-backports). and so are a large number of pidgin-related packages

$ apt-cache search -n pidgin
pidgin-skype - Skype plugin for libpurple messengers (Pidgin-specific files)
pidgin-skype-common - Skype plugin for libpurple messengers (common files)
pidgin-skype-dbg - Skype plugin for libpurple messengers (debug symbols)
pidgin-themes - Smiley themes collection for pidgin
pidgin-guifications - toaster popups for pidgin
indicator-status-provider-pidgin - indicator-messages status provider for pidgin
pidgin - graphical multi-protocol instant messaging client for X
pidgin-data - multi-protocol instant messaging client - data files
pidgin-dbg - Debugging symbols for Pidgin
pidgin-dev - multi-protocol instant messaging client - development files
pidgin-audacious - pidgin integration with Audacious
pidgin-awayonlock - pidgin plugin to set as away on screensaver activation
pidgin-blinklight - Blinks your ThinkPad's ThinkLight upon new messages
pidgin-encryption - pidgin plugin that provides transparent encryption
pidgin-extprefs - extended preferences plugin for the instant messenger pidgin
pidgin-festival - pidgin plugin to hear incoming messages using voice synthesis
pidgin-gmchess - pidgin integration with gmchess
pidgin-gnome-keyring - integrates pidgin (and libpurple) with the system keyring
pidgin-gnome-keyring-dbg - debugging symbols for pidgin-gnome-keyring
pidgin-hotkeys - Configurable global hotkeys for pidgin
pidgin-lastfm - Last.fm plugin for Pidgin
pidgin-latex - Pidgin plugin to display LaTeX formulas
pidgin-libnotify - display notification bubbles in pidgin
pidgin-librvp - MS Exchange RVP instant messaging plugin for Pidgin
pidgin-microblog - Microblogging plugins for Pidgin
pidgin-microblog-dbg - Microblogging plugins for Pidgin (debugging symbols)
pidgin-mpris - sets your available message to your currently playing track
pidgin-mra - Mail.ru Agent protocol plugin for Pidgin IM
pidgin-mra-dbg - Mail.ru Agent protocol plugin for Pidgin IM
pidgin-nateon - Pidgin plugin for NateOn instant messaging service
pidgin-nateon-dbg - debugging symbols of pidgin-nateon
pidgin-openfetion - Fetion protocol plugin for libpurple
pidgin-openpgp - OpenPGP plugin for Pidgin
pidgin-otr - Off-the-Record Messaging plugin for Pidgin
pidgin-privacy-please - plugin for enhanced privacy in pidgin
pidgin-sipe - Pidgin plugin for MS Office Communicator and MS Lync
pidgin-sipe-dbg - Pidgin plugin for MS Office Communicator and MS Lync (debug symbols)
pidgin-twitter - Pidgin plugin for Twitter
pidgin-plugin-pack - Collection of Pidgin plugins

If you really need to build your own local version, download the debian source package (e.g. with apt-get source pidgin), modify the source, and build a package or package(s).

  • this is a bit helpful to see all the packages but if I was trying to build another program not available in in official repos, how could I solve the issue of missing packages? – user1610950 Nov 4 '15 at 5:09
  • install the build-deps for pidgin, probably pidgin-dev too. build a local package (e.g. using debdry and debhelper). Also check the contents of pidgin-plugin-pack just in case it's already in there. – cas Nov 4 '15 at 5:42
  • btw, one common mistake that people make is not realising that the libfoo package ONLY contains the runtime files (e.g. .so libs). If you want to compile programs using that lib, you need to install the libfoo-dev package, which contains the header and .a library. – cas Nov 4 '15 at 5:46
  • See also: wiki.debian.org/DontBreakDebian – cas Nov 4 '15 at 5:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.