3

I want to connect my headset via bluetooth on Debian 8. I run from terminal

systemctl enable bluetooth
systemctl start bluetooth

Then I use gnome-bluetooth, I see the device and try to connect, what happens is just that the connection is lost everytime after less than a second, so that the status of the device become "disconnected". Also If I do not run the commands above, gnome-bluetooth does not see the device. I googled the issue, and it seems it is quite common, but I found no solution.

This is the output of lsusb:

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 04f2:b3d5 Chicony Electronics Co., Ltd 
Bus 001 Device 009: ID 13d3:3393 IMC Networks 
Bus 001 Device 005: ID 1004:631c LG Electronics, Inc. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
2

Solution found, not sure why that works.

sudo apt-get install pulseaudio-module-bluetooth

reboot your system.

sudo systemctl start bluetooth.service

now open the gui utility for the bluetooth and make sure bluetooth is set on "on"

in the terminal type

bluetoothctl

make sure that the command

show

actually shows something similiar to

Name: debiansystem
Alias: debiansystem
Class: 0x0c010c
Powered: yes
Discoverable: yes
Pairable: yes
...

now trust, pair and then connect to your device.

This worked, at least for me

1

I was also having the same problem with bluetooth and Debian 8, tried a lot of things but nothing worked with gnome-bluetooth. I was following the instructions on this page: https://wiki.debian.org/BluetoothUser/a2dp so I did

sudo apt-get install pulseaudio pulseaudio-module-bluetooth pavucontrol bluez-firmware

then

systemctl restart bluetooth

and althought I have the gnome-bluetooth I could not manage to make it work so I installed the blueman-applet by

apt-get install blueman

Then opened the Bluetooth Manager program which I just installed (Make sure gnome-bluetooth is closed) and that's it, I was able to pair my Bluetooth speakers. The only missing step is to open Sound in Settings and choose my Bluetooth speakers as output.

Hope that helps!!

0

I had a problem getting things to work as well, but by just disabling SELinux, the problem had resolved itself:

# First check if this is even your problem, is SELinux enabled?
getenforce

# If the above created the output of '1', then this could very
# well be your problem.. keep reading.

# Disable SELinux
setenforce 0

# Restart bluetooth
systemctl restart bluetooth

You can stop at this step now if you want (connect up your device and work with it). But if you want to fix this for the future, the proper solution would be to update your SELinux library internally (so you can re-enable it):

# Create your own module
grep bluetooth /var/log/audit/audit.log | audit2allow -M mybluetooth

# Install it now:
semodule -i mybluetooth.pp

# Now safely re-enable SELinux:
setenforce 1

In my case it was an entry like this that was causing it:

type=AVC msg=audit(1522596590.758:103): avc:  denied  { mounton } for  pid=999 comm="(uetoothd)" path="/var/lib/bluetooth" dev="dm-0" ino=2362849 scontext=system_u:system_r:init_t:s0 tcontext=system_u:object_r:bluetooth_var_lib_t:s0 tclass=dir permissive=0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.