2

Let me refer responders to this thread on Linux Mint forums:

I've seen this four times in the past two weeks or so. The loss of connection does eventually clear after an unknown time (longest has been 4 days).

In a nut shell, almost all URL-s work but key ones you'd need to do (actual) stuff like google.com, linkedin.com, youtube.com or yahoo.com, etc. fail. While other sites you'd think are related work. It is unpredictable. Tonight is a good example. URL:

The issue affects everything I've tested (for the 'missing' url)...

  • firefox
  • chrome
  • curl
  • wget
  • dig

I don't know if it is specifically the DNS.

(update: 2015-11-11)

The fortunate experience swapping to and back from a mobile broadband modem was not a 'workaround' just a lucky-break. Results from such a swap don't always work.

I think the DNS issue(s) are just a symptom. The message for

curl https//:mail.google.com

Gives back is...

curl: (7) Couldn't connect to server

Which I'm guessing means it can "see" the server but won't connect. As mentioned I can send email from other things using the same access point e.g. Android phone so wondering what diagnostics there are for this kind of thing in Linux Mint so I can get a handle on what part of the stack is getting stuck?

(update: 2015-11-10)

I have some new information. It may help others, or give the brain's trust a tip on how to resolve this problem. This evening I was unable to access GitHub, stackexchange.com, netbeans, and Wikipedia, to name a few. I am here now, so what happened?

When I pressed F5 here, I received this banner message at the top of the screen:

 Unix & Linux Stack Exchange requires external 
 JavaScript from another domain, which is blocked 
 or failed to load.

woops I thought, it has happened again. I really wanted to check for any responses, because as you can imagine this error is retarding significant progress -- So I have a little credit on a USB modem. I thought I'd try to use that.

  1. Swapped-out the WI-FI access point
  2. Connected to the USB/mobile network

Result: No change, can't get wikipedia and the annoying script message thing was showing on this page.

  1. Disconnect from the USB/Mobile broadband network
  2. Reconnect he Wi-Fi access point

One of my Dig tests gave a different result After connecting (back) to the Wi-Fi access point. So (now) ...

  1. The annoying banner message on StackExchange is gone. I can see wikipedia and github again.

It appears that something in the stack doesn't get reset/refreshed until the 'Wired' (access point) connection is reconnected. But not just reconnected; being usurped so that it has to reconnect everything (again).

The other odd thing; is that the mobile broadband did NOT refresh/reset the (effective) stuff on the data comm. stack. Why not? How?

More importantly what may I do to force the reset/refresh on the Wired connection and the Wi-Fi connection without renewing a defunct mobile broadband when the current merger residual credits drip away??!!

Otherwise things remain the same as they were for the last update

(update end)

At the moment all I can say is that google search (working) and gmail (not working) demonstrate the following responses from dig.

$ dig google.com

 ; <<>> DiG 9.9.5-3ubuntu0.5-Ubuntu <<>> google.com
 ;; global options: +cmd
 ;; Got answer:
 ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 19398
 ;; flags: qr rd ra; QUERY: 1, ANSWER: 15, AUTHORITY: 0, ADDITIONAL: 0

 ;; QUESTION SECTION:
 ;google.com.           IN  A

 ;; ANSWER SECTION:
 google.com.        114 IN  A   120.19.255.38
 google.com.        114 IN  A   120.19.255.27
 google.com.        114 IN  A   120.19.255.19
 google.com.        114 IN  A   120.19.255.59
 google.com.        114 IN  A   120.19.255.53
 google.com.        114 IN  A   120.19.255.29
 google.com.        114 IN  A   120.19.255.15
 google.com.        114 IN  A   120.19.255.49
 google.com.        114 IN  A   120.19.255.57
 google.com.        114 IN  A   120.19.255.34
 google.com.        114 IN  A   120.19.255.23
 google.com.        114 IN  A   120.19.255.45
 google.com.        114 IN  A   120.19.255.44
 google.com.        114 IN  A   120.19.255.42
 google.com.        114 IN  A   120.19.255.30

 ;; Query time: 108 msec
 ;; SERVER: 127.0.1.1#53(127.0.1.1)
 ;; WHEN: Tue Nov 03 23:14:22 AEDT 2015
 ;; MSG SIZE  rcvd: 268

and $ dig mail.google.com

 ; <<>> DiG 9.9.5-3ubuntu0.5-Ubuntu <<>> mail.google.com
 ;; global options: +cmd
 ;; Got answer:
 ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 40641
 ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

 ;; QUESTION SECTION:
 ;mail.google.com.      IN  A

 ;; AUTHORITY SECTION:
 .          49606   IN  NS  localhost.

 ;; Query time: 106 msec
 ;; SERVER: 127.0.1.1#53(127.0.1.1)
 ;; WHEN: Tue Nov 03 23:15:02 AEDT 2015
 ;; MSG SIZE  rcvd: 55

In contrast the dig output on a working box I have access to shows a different story as far as nameservers go.

On a working machine: $ dig gmail.com (added in update)

 ; <<>> DiG 9.6-ESV-R11 <<>> gmail.com
 ;; global options: +cmd
 ;; Got answer:
 ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 22330
 ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

 ;; QUESTION SECTION:
 ;gmail.com.                     IN      A

 ;; ANSWER SECTION:
 gmail.com.              192     IN      A       216.58.220.101

 ;; Query time: 15 msec
 ;; SERVER: 192.168.172.1#53(192.168.172.1)
 ;; WHEN: Wed Nov 04 14:02:50 EST 2015
 ;; MSG SIZE  rcvd: 43

In the first non-working example, the Linux set-up is using localhost. To me, that sounds like I need it to do a refresh or something. Comments?

Nitty gritty detail, is:

  • Linux Mint v17.2 - Rafaela (Cinnamon 64-bit)
  • dnsmasq version 2.68

I tested the network restart suggested on the forum, alas it didn't assist me accessing gmail. Back to the drawing boars/stackexchange :-)

Apart from the question on the Mint forum I haven't found anything to indicate 'yea' or 'nay' for this problem. The first post on this issue was way back in 2011 and it looks like it was skipped as a 'non-good' question so this phenomena has been about for a while. It would be good to find an effective response. Hopefully one of us has a fix already.

Suggestions welcome and happy to look-up further information.

  • looking around, there are MANY people reporting this problem. And (sad to say) quite a few folk dis-ing on the question, instead of being helpful. E.g. Why can't I access my gmail account while using Linux Mint but have no problem with my account using Windows -- I picked this one at random but ... It seems the problem is in the Linux set-up; my Android device sees gmail and both this and my PC use the same wifi access point. – will Nov 3 '15 at 14:00
  • 1st of all, you should edit your question instead of commenting on it :-) Have you used dig with the @ option to point it at your router?. For example dig @192.168.0.1 mail.google.com. That will bypass dnsmasq (if you've configured your machine to use it as the DNS server) and may help narrow down the problem. – garethTheRed Nov 3 '15 at 16:06
1

(update: 2015-12-16)

These last few days I had occasion to use-up the remaining MB-s on the USB modem. I have had exactly zero DNS issues.

At one point I lent the USB wireless broadband modem to someone; and used the micro-USB via a mobile phone (same network provider). DNS issues returned in very short shrift!

The workaround seems to be avoid micro-USB wired connections (mobile phones). Or connect via wi-fi.


I may have a path forward, if not an actual solution. For this problem I need to see how it plays out over a say a month and ensure there's no outages.

This system has a new install of Linux Mint 17.2 - Rafaela. I haven't knowingly touched the network set-up prior to having troubles. It more or less worked fine initially. As this was an intermittent problem I can't say.

Looking at the Mint page, I found this system was missing the

  • /etc/dnsmasq.conf config file

So I decided to (re-)install dnsmasq

sudo apt-get install dnsmasq

And work through the tutorial as well as referring to the subsection on using Google DNS wiki page. And restarted dnsmasq.

sudo /etc/init.d/dnsmasq restart

In any case, sometimes the best thing is to reinstall and ensure you have a clean slate. Tests so far show things working fine. The DNS cache definitely was NOT working before I reinstalled. My dig time is now close to zero on common domains! yea

Hope that helps other. Btw I saw lots of information about putting back NetworkManager. As I understand that, NetworkManager is an Alternate to a DNSmasq set-up. I welcome clarification on that part. In a any case the two are not compatible together as far as I know.

At present DNSmasq is better for me. It, it has been in Debian -> Ubuntu -> Mint for some time so it's a fair comment to say it's the better option most of the time.

some resources:

  1. Local DNS Cache for Faster Internet Browsing on your Linux Mint
  2. dnsmasq (ubuntu)
  3. howto dnsmasq (debian)
  4. Prevent OpenDNS Redirecting_Google Queries

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.