0

I compiled ExpressI.exe on a Windows system with Visual C++. The file ExpressI.exe resides on a share mounted from Linux.

I need to permit only the program ExpressI.exe to access the test folder that contains ExpressI.exe on the Linux share. So I logged on to the Linux server and set the owner of every file in the test folder to user vek and gave setuid permission on the executable file ExpressI.exe. I got the idea from Jenny D on this link How do I disable copy permissions?

Now I'm running it on a Windows 10 machine (not under WINE) connected to the Linux share.

The problem is when some other user (not user 'vek') runs this executable file on Windows 10, they cannot access the test folder.

Please see below picture. How can I resolve this problem?

setuid won't work

closed as off-topic by Mikel, cas, jordanm, Raphael Ahrens, garethTheRed Nov 3 '15 at 7:37

  • This question does not appear to be about Unix or Linux within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Windows exe files could not be run in Linux environments unless only through layers like Wine. And Wine does not support setuid. – user140866 Nov 3 '15 at 3:42
  • Thanks siblynx, and in case of I'm run it on Windows 10 system not linux environment, is it still not work? – user3571241 Nov 3 '15 at 3:58
  • What is machine 192.168.10.254 you're trying to run it on? What OS does it run? – user140866 Nov 3 '15 at 4:01
  • 4
    I'm voting to close this question as off-topic because this question belongs on superuser.com – cas Nov 3 '15 at 4:58
  • 1
    @cas Since the files are on a Linux server, doesn't that satisfy "Using or administering a *nix desktop or server"? – RobertL Nov 3 '15 at 7:43
2

You cannot affect a user in windows by setting the setuid bit in Linux.

Windows does not see or use the setuid bit on a file from a Linux server.

Windows has no concept or mechanism of setuid.

  • You're welcome. If you think my answer is correct, please accept it by clicking the check mark. – RobertL Nov 4 '15 at 2:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.