3

I'm using Kali Linux, latest edition and in the last two weeks it has auto-updated packages. I wasn't aware of this until I saw a notification bubble and when I checked out the GNOME PackageKit updater, it showed updates on three days when I had only booted up the computer and did not explicitly update any packages myself.

I already looked for the apt-get Periodic configuration setting to see if that was the cause and could not find anything in /etc/apt-get/ that suggested apt was handling the automatic updating setting.

I also looked at the settings for PackageKit and it doesn't have anything related to automatic updates.

At this point I'm lost and I'm not sure how to turn off automatic updates in Kali Linux. For a security-oriented distro it's extremely frustrating that it would just use up bandwidth and make contact with the outside world automatically.

4

open dconf-editor and navigate to

org -> gnome -> software

and change this key to false

download-updates

source

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.