0

I have just installed Fedora 22 and am new to the Linux environment. My problem is this, at startup the GPU doesn't seem to auto detect the resolution of my monitor.

xrandr --newmode "1440x900_60.00"  106.50  1440 1528 1672 1904  900 903 909 934 -hsync +vsync
xrandr --addmode DVI-1 "1440x900_60.00"
xrandr --output DVI-1 --mode "1440x900_60.00"

So far I was doing this to allow me to change the resolution on my monitor however it is a temporary solution. Is there a way that allows me to run those commands at startup? I believe I had already tried to use "rcon" yesterday but that didn't work.

2
  • What video card? And what monitor, for that matter? This is almost certainly due to a bug (and a bug report would be appreciated).
    – mattdm
    Nov 2, 2015 at 18:56
  • You may also want to try Fedora 23 — out tomorrow! — to see if it fixes this problem.
    – mattdm
    Nov 2, 2015 at 18:57

1 Answer 1

-2

Put your commands in an .xinitrc file in your home directory. The last one should actually be enough.

7
  • Am I meant to create it if it's not there? (Just checking... I'm new to this) if I am can I just do touch xinitrc ?
    – Ziky
    Nov 2, 2015 at 13:27
  • I'm assuming I also have to use #!/bin/bash at the start, don't I?
    – Ziky
    Nov 2, 2015 at 13:33
  • no, .xinitrc gets read when your user's X session starts. Don't forget the .. The file should be named .xinitrc as opposed to xinitrc. Create the file, if it is not already there.
    – blissini
    Nov 2, 2015 at 13:57
  • right so I dont need to use #!/bin/bash at the start... as that didn't work, yes?
    – Ziky
    Nov 2, 2015 at 14:09
  • Tried, no success :/
    – Ziky
    Nov 2, 2015 at 14:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .