1

I am having trouble getting my display to work with the default debian kernel command line:

\boot\vmlinuz-4.2.0-0.bpo.1-amd64 ro root=UUID=4e496eaa-bcf1-41a0-9eee-dd1c8367c855 initrd=boot\initrd.img-4.2.0-0.bpo.1-amd64

If I try to just let the laptop boot with that default command line argument I get met with a grey "oh, no something was wrong" error message.

enter image description here

I found that if I change that kernel command line to:

\boot\vmlinuz-4.2.0-0.bpo.1-amd64 ro root=UUID=4e496eaa-bcf1-41a0-9eee-dd1c8367c855 initrd=boot\initrd.img-4.2.0-0.bpo.1-amd64 2

or append 3 it boots to gnome-shell then I can login, startx and be taken to my desktop with no problems at all.

what could be the cause of this issue and how can I fix it to have an expected behavior?

how did I edit my kernel line

sudo vi /etc/default/grub 
GRUB_CMDLINE_LINUX_DEFAULT =""
GRUB_CMDLINE_LINUX="text"
GRUB_TERMINAL="console"
sudo update-grub

reboot and still ended up at the screen shot attached above.

if instead when I come to the grub menu I edit the kernel string from:

\boot\vmlinuz-4.2.0-0.bpo.1-amd64 ro root=UUID=4e496eaa-bcf1-41a0-9eee-dd1c8367c855 initrd=boot\initrd.img-4.2.0-0.bpo.1-amd64

and add a 2 or 3 to the very end like this

\boot\vmlinuz-4.2.0-0.bpo.1-amd64 ro root=UUID=4e496eaa-bcf1-41a0-9eee-dd1c8367c855 initrd=boot\initrd.img-4.2.0-0.bpo.1-amd64 2

then I will boot to the command line, from there I can login, startx and get to my desktop.

I posted an answer to this question which was to basically purge nvidia* from my system. It works but I will eventually need nvidia drivers since I program opengl{es} and would like to move my development to linux.

  • 1
    Haven't you already found a fix? I thought you wrote that changing the kernel command line to what you show fixes it. By the way, while they do sometimes work, don't use Windows style paths (foo\bar) in the *nix world, use *nix style foo/bar instead. – terdon Nov 1 '15 at 16:57
  • that's the default string that debian created, I don't think I should change that. Also appending 2 or 3 to the end of that line seems a bit strange. I was just testing and if I login, edit grub, update grub and reboot, while the edits are there grub doesn't seem to pay attention to the changes. Honestly I'd just like the laptop to boot up and go to the login screen instead of booting up, editing kernel string, logging in, then doing startx. – user1610950 Nov 1 '15 at 17:02
  • OK, but if you've found that appending 2 or 3 fixes it, edit the kernel line. I'd be happy to post an answer explaining how to do that if that's the issue. – terdon Nov 1 '15 at 17:05
  • I edited the kernel line, updated grub but I still get that oh no! screen. – user1610950 Nov 1 '15 at 17:07
  • Please edit your question and explain exactly what you did (which files did you edit, what commands did you run) to update your kernel line. – terdon Nov 1 '15 at 17:16
1

I am not sure, maybe there are bugs with the latest nvidia drivers but this is the steps I took to be able to actually launch back into my desktop without fiddling with any command line arguments or kernel strings.

Booted with the above mentioned steps by appending 2 to the end of the kernel string, like this:

\boot\vmlinuz-4.2.0-0.bpo.1-amd64 ro root=UUID=4e496eaa-bcf1-41a0-9eee-dd1c8367c855 initrd=boot\initrd.img-4.2.0-0.bpo.1-amd64 2

from the command line I ran these with sudo:

apt-get remove --purge nvidia*
rm /etc/X11/xorg.conf
apt-get update
apt-get autoremove

reboot

after that I was able to get right back to gnome login manager. Whatever the reason nvidia drivers aren't playing well.

  • Yes, that will work. The initial problem was that you were booting to the wrong runlevel. Adding 2 made you boot to the second runlevel which is usually a normal system from which you can run startx. – terdon Nov 1 '15 at 17:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.