I am quite puzzled as to why ssh requires password Authentication although i have generated and copies keys.

I installed Ubuntu mini 14.04, and for whatever the reason I am not able to connect to it without a password via SSH.

At first I believed it was an issue with the guest machine which generated and copied the keys, however that is not the case. Here is what I have done. Machine A (Let’s call it Client), Machine B (Ubuntu Mini, let’s call it Server). Somehow what to do on which machine gets a little confusing on many of the instructions I have found.

  1. Delete all entries in /home/user/.ssh on both the Client and the Server (making sure it was all clean)

On Client

  1. Generated keys ssh-keygen on the client, went through the questions and did not apply a password.
  2. Copied keys to server ssh-copy-id username@192.168.1.2 - entered password.
  3. SSH’d into server, client machine prompt for password, I check the make sure the key had been copied over the server. It was listed in the servers /home/users/.ssh/authorized_keys file

  4. I checked permission on /home/user/.ssh folder and made sure it was 700

SSH always requires a password.

I repeated the same process on the server and was able to auto login via ssh to the client.

SSH Directory on Server

    username@Server:~$ ls -ld .ssh
    drwx------ 2 username username 4096 Oct 27 08:24 .ssh

.SSH Directory Contents on Server

    username@Server:~/.ssh$ ls -l
    total 16
    -rw------- 1 username username 789 Oct 26 21:08 authorized_keys
    -rw------- 1 username username 1675 Oct 26 20:37 id_rsa
    -rw-r--r-- 1 username username 400 Oct 26 20:37 id_rsa.pub
    -rw-r--r-- 1 username username 222 Oct 26 20:37 known_hosts

Authorized Keys on Server

    username@Server:~/.ssh$ cat authorized_keys
    ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABAQDJKqmBuPPxzFx/opVJhNQNiUUHLQIT4n2ScQljni489ONzUXmTC8fAhGprDFUhVs GZrlFm+RJrmu5VlasG+dLG33Y7mXTnhsj5FVjUzbbliUbVqizR di18Gh6AM5VyiSqSh/prDmT5xpasQLQopGmB3kxCP6+6RnKnovUk8f4UOs4i0HXZM9VM EnwgPkN9v6LTTI7VI2QApLl/c1aYfMF2jOua/T7Xw4hdz+DbzEQi8ygk9NYpbE1QB8l4TB2Ls6hwBEVlSeHcP3H 6RX8a71ow+qGz5Zz9cK5Eg6v3OKK6YXcwS2osePWgMmJsNW/mVgne3pQvoajIZyMx9+r9mCIF pi@PiScanner

RSA Public keys on Client

     pi@PiScanner ~/.ssh $ cat id_rsa.pub
        ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABAQDJKqmBuPPxzFx/opVJhNQNiUUHLQIT4n2ScQljni489ONzUXmTC8fAhGprDFUhVs GZrlFm+RJrmu5VlasG+dLG33Y7mXTnhsj5FVjUzbbliUbVqizR di18Gh6AM5VyiSqSh/prDmT5xpasQLQopGmB3kxCP6+6RnKnovUk8f4UOs4i0HXZM9VM EnwgPkN9v6LTTI7VI2QApLl/c1aYfMF2jOua/T7Xw4hdz+DbzEQi8ygk9NYpbE1QB8l4TB2Ls6hwBEVlSeHcP3H 6RX8a71ow+qGz5Zz9cK5Eg6v3OKK6YXcwS2osePWgMmJsNW/mVgne3pQvoajIZyMx9+r9mCIF pi@PiScanner

pi@PiScanner ~/.ssh $ ssh -vvv username@192.168.101.2

OpenSSH_6.0p1 Debian-4+deb7u2, OpenSSL 1.0.1e 11 Feb 2013
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to 192.168.101.2 [192.168.101.2] port 22.
debug1: Connection established.
debug3: Incorrect RSA1 identifier
debug3: Could not load "/home/pi/.ssh/id_rsa" as a RSA1 public key
debug1: identity file /home/pi/.ssh/id_rsa type 1
debug1: Checking blacklist file /usr/share/ssh/blacklist.RSA-2048
debug1: Checking blacklist file /etc/ssh/blacklist.RSA-2048
debug1: identity file /home/pi/.ssh/id_rsa-cert type -1
debug1: identity file /home/pi/.ssh/id_dsa type -1
debug1: identity file /home/pi/.ssh/id_dsa-cert type -1
debug1: identity file /home/pi/.ssh/id_ecdsa type -1
debug1: identity file /home/pi/.ssh/id_ecdsa-cert type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_6.6.1p1 Ubuntu-2ubuntu2.3
debug1: match: OpenSSH_6.6.1p1 Ubuntu-2ubuntu2.3 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_6.0p1 Debian-4+deb7u2
debug2: fd 3 setting O_NONBLOCK
debug3: load_hostkeys: loading entries for host "192.168.101.2" from file "/home/pi/.ssh/known_hosts"
debug3: load_hostkeys: found key type ECDSA in file /home/pi/.ssh/known_hosts:1
debug3: load_hostkeys: loaded 1 keys
debug3: order_hostkeyalgs: prefer hostkeyalgs: ecdsa-sha2-nistp256-cert-v01@openssh...01@openssh.com,ecdsa-sha2-nistp52 1-cert-v01@openssh.com,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug2: kex_parse_kexinit: ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group-excha nge-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
debug2: kex_parse_kexinit: ecdsa-sha2-nistp256-cert-v01@openssh...01@openssh.com,ecdsa-sha2-nistp521-cert-v01@openssh.c om,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,ssh-rsa-cert-v01@openssh.com,ssh-dss-cert-v01@openssh.com,ssh-rsa-cert-v00@openssh.c om,ssh-dss-cert-v00@openssh.com,ssh-rsa,ssh-dss
debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cb c,arcfour,rijndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cb c,arcfour,rijndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-sha2-256,hmac-sha2-256-96,hmac-sha2-512,hmac-sha2-512-96,hmac-ripemd160,hmac -ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-sha2-256,hmac-sha2-256-96,hmac-sha2-512,hmac-sha2-512-96,hmac-ripemd160,hmac -ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
debug2: kex_parse_kexinit:
debug2: kex_parse_kexinit:
debug2: kex_parse_kexinit: first_kex_follows 0
debug2: kex_parse_kexinit: reserved 0
debug2: kex_parse_kexinit: curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha2 56,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
debug2: kex_parse_kexinit: ssh-rsa,ssh-dss,ecdsa-sha2-nistp256,ssh-ed25519
debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-gcm@openssh.com,aes256-gcm@openssh.com,chacha20-poly1305@o penssh.com,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-gcm@openssh.com,aes256-gcm@openssh.com,chacha20-poly1305@o penssh.com,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit: hmac-md5-etm@openssh.com,hmac-sha1-e...tm@openssh.com,hmac-sha2-256-etm@op enssh.com,hmac-sha2-512-etm@openssh.com,hmac-ripemd160-etm@openssh.com,hmac-sha1-96-etm@openssh.com,hmac-md5-96-etm@openssh.com,hmac-md5,hmac-sha1, umac-64@openssh.com,umac-128@openssh...60@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: hmac-md5-etm@openssh.com,hmac-sha1-e...tm@openssh.com,hmac-sha2-256-etm@op enssh.com,hmac-sha2-512-etm@openssh.com,hmac-ripemd160-etm@openssh.com,hmac-sha1-96-etm@openssh.com,hmac-md5-96-etm@openssh.com,hmac-md5,hmac-sha1, umac-64@openssh.com,umac-128@openssh...60@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: none,zlib@openssh.com
debug2: kex_parse_kexinit: none,zlib@openssh.com
debug2: kex_parse_kexinit:
debug2: kex_parse_kexinit:
debug2: kex_parse_kexinit: first_kex_follows 0
debug2: kex_parse_kexinit: reserved 0
debug2: mac_setup: found hmac-md5
debug1: kex: server->client aes128-ctr hmac-md5 none
debug2: mac_setup: found hmac-md5
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: sending SSH2_MSG_KEX_ECDH_INIT
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ECDSA 73:78:68:3b:58:0d:78:a9:64:96:6e:9c:ca:0c:ae:9f
debug3: load_hostkeys: loading entries for host "192.168.101.2" from file "/home/pi/.ssh/known_hosts"
debug3: load_hostkeys: found key type ECDSA in file /home/pi/.ssh/known_hosts:1
debug3: load_hostkeys: loaded 1 keys
debug1: Host '192.168.101.2' is known and matches the ECDSA host key.
debug1: Found key in /home/pi/.ssh/known_hosts:1
debug1: ssh_ecdsa_verify: signature correct
debug2: kex_derive_keys
debug2: set_newkeys: mode 1
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug2: set_newkeys: mode 0
debug1: SSH2_MSG_NEWKEYS received
debug1: Roaming not allowed by server
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug2: service_accept: ssh-userauth
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug2: key: /home/pi/.ssh/id_rsa (0x782a3308)
debug2: key: /home/pi/.ssh/id_dsa ((nil))
debug2: key: /home/pi/.ssh/id_ecdsa ((nil))
debug1: Authentications that can continue: publickey,password
debug3: start over, passed a different list publickey,password
debug3: preferred gssapi-keyex,gssapi-with-mic,publickey,keyboard-interactive,password
debug3: authmethod_lookup publickey
debug3: remaining preferred: keyboard-interactive,password
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Offering RSA public key: /home/pi/.ssh/id_rsa
debug3: send_pubkey_test
debug2: we sent a publickey packet, wait for reply
debug1: Authentications that can continue: publickey,password
debug1: Trying private key: /home/pi/.ssh/id_dsa
debug3: no such identity: /home/pi/.ssh/id_dsa
debug1: Trying private key: /home/pi/.ssh/id_ecdsa
debug3: no such identity: /home/pi/.ssh/id_ecdsa
debug2: we did not send a packet, disable method
debug3: authmethod_lookup password
debug3: remaining preferred: ,password
debug3: authmethod_is_enabled password
debug1: Next authentication method: password
username@192.168.101.2's password:

Cannot get this to auto log in! any assistance would be greatful! thank you.

  • please, post log from server, which contains the reason for rejecting your key. It should be /var/log/auth.log – Jakuje Oct 31 '15 at 17:13
  • you mention "public key on client", client must use private key. – Archemar Oct 31 '15 at 17:15
  • Private fails also auth.log dl.dropboxusercontent.com/u/58850968/auth.log i notice two itemd sshd[1729]: Authentication refused: bad ownership or modes for directory /home/ylafont and constant pam_windfind erros – user68650 Oct 31 '15 at 17:39

Possible cause: is your id_rsa file corrupted?

I see these lines in the log that look suspicious:

debug3: Incorrect RSA1 identifier
debug3: Could not load "/home/pi/.ssh/id_rsa" as a RSA1 public key

I have no such message when I do an ssh connection...

  • i have generated the id_rsa file several times in trying to fix this issue. i cannot be corrupt – user68650 Oct 31 '15 at 17:59

Solved! The permissions to /home/username must also be set to 744. This is not very clear anywhere I looked.

  • 1
    I'm almost 1000% certain that those are not permissions you want to set on a directory. – Shadur Apr 6 '17 at 8:39

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.