1

I recently discovered how to connect to a PTP-compatible camera from Linux so I figured I could do the same from a Galileo Gen 2 board, only to find out that it's not as easy as I thought. The Yocto Linux image I'm using is iot-devkit-201510010757-mmcblkp0-galileo

The first riddle was installing libgphoto2. I started by downloading a copy of libgphoto 2.5.4 on my Galileo(actually used WinSCP to transfer it) and tried to run ./configure, only to find out that I have a missing dependency, namely libtool-ltld. The specific error message was:

libgphoto2 requires libltdl (the libtool dl library)*

Ok, searching for that I discovered the GNU libtool site and proceeded to try to install that. For whatever reasons I've completely forgot( it's been 6 hours of searching for a solution now), I couldn't install it( I think make and make install might have worked but libgphoto still complained about not having libtool-ltld?). So I went another route for installing this.

On whatever site/forum somebody suggested the usage of another repository for the opkg package manager, namely AlexT's repo for Galileo. Good, I've put in base-feeds.conf the links provided there and tried to run opkg update only to get a "wget: bad address" error(holy crap dude, I'm just trying to install a library!). Turns out I manually had to put the 8.8.8.8 and 8.8.4.4 Google DNS servers in resolv.conf.

opkg list looks like a total mess now, but at least I can finally install libgphoto2-2. Of course, I have to -force-overwrite install it because there are some conflicts but I don't care at this point. Turns out the installed version is 2.4.11.

gphoto2 isn't on the repo unfortunately, so I download again the gphoto2 2.4.11 version and try to run ./configure. The result?

configure: error: PKG_CONFIG_PATH= LIBGPHOTO2_LIBS= LIBGPHOTO2_CFLAGS=

  • Fatal: gphoto2 command line interface requires libgphoto2 >= 2.5.6 to build. *
  • Possible solutions:
    • set PKG_CONFIG_PATH to adequate value
    • call configure with LIBGPHOTO2_LIBS=.. and LIBGPHOTO2_CFLAGS=..
    • call configure with one of the --with-libgphoto2 parameters
    • get libgphoto2 and install it

When typing export there is not PKG_CONFIG_PATH to be found and I really wasted all of my known options on how to resolve this. libgphoto2 seems to be installed, at least I found these files in /usr/lib :

  • libgphoto2.so.2
  • libgphoto2.so.2.4.0
  • libgphoto2_port.so.0
  • libgphoto2_port.so.0.8.0

What am I doing wrong?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.