1

I bought a network interface to finally make my (persistent) live usb Kali work on my Macbook pro.

  • Network Interface : DLink Wireless N Nano Usb Adapter DWA-131 E1 which uses the Realtek RTL8192EU chipset

The problem is I can't install the drivers.

According to this site I can use the following drivers:

possibly r8192u_usb, r8712u, or rtl8192cu (in backports) or maybe something else depending on chipset

I tried downloading the chipset drivers (RTL8192CU) from realtek (here) After unzipping, going into the /driver/ directory and make and make install I get the following error:

make[1]: *** /lib/modules/4.0.0-kali1-amd64/build: No such file or directory.  Stop.

How do I make this work? Any help is really appreciated.

Thanks a lot for your help!

Cheers.

closed as too broad by Jeff Schaller, GAD3R, Stephen Rauch, Satō Katsura, G-Man Nov 4 '17 at 15:25

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • I bought one of these earlier this year and was unable to get it to work. given that it was only about $10, i gave up and bought an Atheros AR9271 based wifi usb stick which uses the ath9k driver, also for about $10. both of them were cheap TP-Link brand devices. The r8192cu has better specs, and is better...or would be if it worked on linux. but the Atheros is good enough and has the bonus feature of actually working on linux. – cas Oct 30 '15 at 4:03
  • Possible duplicate of Why is Kali Linux so hard to set up? Why won't people help me? – G-Man Nov 4 '17 at 15:25