0

Note I already asked the exact same question here, with no success. I hope it's not a problem.

I am working on a computer connected to a LDAP server. The computer is running under Linux Mint 17. I installed acroread with

su root
add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"
apt-get update
apt-get install acroread

When running acroread as root, everything is normal, Adobe Reader opens. When running as unpriviledged user, nothing happens, no error, no windows.

I tried

ps -e | grep acroread

to see if something was running but it did not return anything.

Would you have any ideas why this would happen? I guess it is due to the fact that I /home and /share are mounted from the LDAP server.

Edit This question was originally asked on superuser.SE. User @terdon asked me not to cross-post on several SE, so I copy the other answer I had on superuser.SE as it does not exactly answer the question but still, may be useful.


Credits to PositronicBrain (superuser.SE user):

First, open a command terminal and uninstall the acroread:

$ sudo apt-get --purge remove acroread
$ sudo apt-get --purge remove acroread-bin

(The package names can be obtained with this command: )

$ dpkg -l | grep -i acroread

Now, follow the instructions below to install Adobe Reader 9.5.5 2013, which is the latest version available for GNU/Linux from the Adobe website:

Download the installer:

$ wget -c ftp://ftp.adobe.com/pub/adobe/reader/unix/9.x/9.5.5/enu/AdbeRdr9.5.5-1_i386linux_enu.deb

Use dpkg to install the package:

$ sudo dpkg -i AdbeRdr9.5.5-1_i386linux_enu.deb

Open the Adobe Reader and be happy:

$ acroread

(it works for 32-bit processors)

To uninstall:

$ sudo dpkg --purge adobereader-enu
  • I don't see why it should matter that /home and /share are remote mounts, but that doesn't mean Adobe hasn't assumed something. You could try running strace acroread to see if it starts but crashes. Oh. mkdir /tmp/home; export OHOME="$HOME" HOME=/tmp/home; cp -a "$OHOME"/.??* /tmp/home; cd then try running acroread – roaima Oct 29 '15 at 22:49
  • Please don't cross-post on multiple sites of the SE network. Choose one site and delete the question from the other. Otherwise, both could end up closed. – terdon Oct 30 '15 at 0:44
  • 1
    @terdon the OP asked their other instance of this question six weeks ago and got no satisfactory answers. It doesn't seem unreasonable to me that they should try elsewhere on SE? – roaima Oct 30 '15 at 0:59
  • @roaima it isn't which is why I haven't closed this. I am just suggesting that they delete one or the other. If they want to keep this one, then the one on Super User should be deleted. – terdon Oct 30 '15 at 1:00
  • @terdon: I'm not convinced by the relevance of your request (maybe a Meta post addresses this point?) but as a moderator, you must have good reasons for it. It deleted the other post. – anderstood Nov 2 '15 at 21:09
3

a) Stop using the old unix acroread as it probably hasn't seen security updates in years or b) use the LD_PRELOAD trick to fake out the passwd file open or c) manually add the necessary user accounts to the local passwd file.

I've had to install it on LDAPified machines, and it fails, and rummages through the passwd file:

$ strace -e trace=file -o ugh acroread

(acroread:17602): GLib-WARNING **: getpwuid_r(): failed due to unknown user id (1234)
...
$ grep passwd ugh
open("/etc/passwd", O_RDONLY|O_CLOEXEC) = 3
open("/etc/passwd", O_RDONLY|O_CLOEXEC) = 3
open("/etc/passwd", O_RDONLY|O_CLOEXEC) = 3

So one "fix" was indeed to add user entries to the passwd file.

  • +1 for the advice against acroread. The other things don't make much sense, though; it's not likely to be related to account issues. I've run acroread on LDAPified machines in the past, no problem. – Wouter Verhelst Oct 29 '15 at 22:29
  • you forgot d) never, ever run programs like acroread as root. – cas Oct 29 '15 at 22:36
  • 1
    Thank you, this works! I'll come back and accept as soon as I understood why it worked. Just a note on why I need to use acroread: it's the only possibility under Linux, to my knowledge, to read animations in pdf (e.g. produced with beamer). I think everybody agrees there is a need for a alternate solution. – anderstood Oct 29 '15 at 23:04
  • Could you explain ugh please? – anderstood Oct 30 '15 at 3:48
  • @anderstood the man page for strace explains -o filename quite clearly – roaima Oct 30 '15 at 9:35
1

I had the same problem (acroreader runs only as root), on linux mate x64, with ldap.

Just installed libnss-ldap:i386 and it worked as ldap user with no problem.

  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. - From Review – countermode Dec 20 '16 at 14:02
  • @countermode Maybe xKill edited his comment after your comment, but I think it answer the question (relevantly or not, that's another question and unfortunately, I cannot check it). – anderstood Dec 20 '16 at 15:13
0

I solved the problem on Fedora 64 bits by installing the 32 bits sssd-client:

dnf install -y sssd-client.i686

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.