1

My BIOS does not include an option to disable my intergrated GPU, bumblebee/primusrun provide terrible performance, nouveau doesn't support 900 series GPUs (and has subpar performance too anyways) and finally the proprietary nvidia drivers switching solution (i.e. configuring X11 to disable the iGPU and use only the Nvidia GPU on the Nvidia Proprietary Drivers) comes with terrible tearing problems by not supporting VSYNC and a couple of other breakages (like some QT programs not working and whatnot)

Leaving me with wanting to just use the proprietary drivers the same way as I would on a desktop by disabling the igpu, except of course, like I said, my BIOS doesn't support disabling it.

So I was wondering if theres a way I could disable it another way, like blacklisting the igpu driver or a commandline (grub) option I could use on boot to disable it so that I won't have to deal with this nightmare. I use arch linux.

  • I think Optimus has no provisions for the kind of operation that you want. Well, at least that's what I concluded from the descriptions of how it works. And that might be the reason why you've found no BIOS settings to achieve this. – Laszlo Valko Oct 29 '15 at 19:49
  • @LaszloValko There are plenty of laptops that do come with this BIOS option, mine just doesn't. – Cestarian Oct 30 '15 at 6:11
  • What a coincidence, maybe Nvidia's PRIME is now slightly more usable :O phoronix.com/scan.php?page=news_item&px=PRIME-Sync-Tearing (I still would prefer to disable the igpu and just use the nvidias card, for now) – Cestarian Nov 1 '15 at 15:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.