7

It's long time I'm trying to fix my .conkyrc configuration file in order to set real transparency.

There are many post out there about it, but none of them helped in my case, it seems the solution depends on many factors(windows manager, desktop environment, conky version and probably others).

Actually it seems that my environment support real transparency since it works for my terminal(see Screenshot), but conky is using fake transparency(files on Desktop are covered/overridden)

conky fake transparency

As you can see, I use Metacity as window manager, Mate as desktop environment. I installed conky 1.9 :

conky -version
Conky 1.9.0 compiled Wed Feb 19 18:44:57 UTC 2014 for Linux 3.2.0-37-generic (x86_64)

And my distro is Mint 17.2 Rafaela:

lsb_release -a
No LSB modules are available.
Distributor ID: LinuxMint
Description:    Linux Mint 17.2 Rafaela
Release:    17.2
Codename:   rafaela

My .conkyrc actually is as following:

background yes
use_xft yes
xftfont Roboto:size=9
xftalpha 0.8
update_interval 1
total_run_times 0
own_window yes
own_window_transparent yes
##############################################
# Compositing tips:
# Conky can play strangely when used with
# different compositors. I have found the
# following to work well, but your mileage
# may vary. Comment/uncomment to suit.
##############################################
## no compositor
#own_window_type conky
#own_window_argb_visual no

## xcompmgr
#own_window_type conky
#own_window_argb_visual yes

## cairo-compmgr
own_window_type desktop
own_window_argb_visual no
##############################################
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
double_buffer yes
draw_shades no
draw_outline no
draw_borders no
draw_graph_borders no
stippled_borders 0
#border_margin 5 #commento non è supportato
border_width 1
default_color EDEBEB
default_shade_color 000000
default_outline_color 000000
alignment top_right
minimum_size 600 600
maximum_width 900
gap_x 835
gap_y 77
alignment top_right
no_buffers yes
uppercase no
cpu_avg_samples 2
net_avg_samples 2
short_units yes
text_buffer_size 2048
use_spacer none
override_utf8_locale yes
color1 212021
color2 E8E1E6
color3 E82A2A
own_window_argb_value 0
own_window_colour 000000
TEXT
${goto 245}${voffset 25}${font GeosansLight:size=25} Today
${goto 124}${voffset -}${font GeosansLight:light:size=70}${time %I:%M}${image .conky/line.png -p 350,27 -s 3x189}
${offset 150}${voffset -55}${font GeosansLight:size=17}${time %A, %d %B}
${offset 380}${voffset -177}${font GeosansLight:size=25}Systems${font GeosansLight:size=22}
${offset 400}${voffset 5}${font GeosansLight:size=15}$acpitemp'C
${offset 400}${voffset 10}${cpu cpu0}% / 100%
${offset 400}${voffset 4}$memfree / $memmax${font GeosansLight:size=15}
${offset 400}${voffset 5}${if_up wlan0}${upspeed wlan0} kb/s / ${totalup wlan0}${endif}${if_up eth0}${upspeed eth0} kb/s / ${totalup eth0}${endif}${if_up ppp0}${upspeed ppp0} kb/s / ${totalup ppp0}${endif}
${offset 400}${voffset 5}${if_up wlan0}${downspeed wlan0} kb/s / ${totaldown wlan0}${endif}${if_up eth0}${downspeed eth0} kb/s / ${totaldown eth0}${endif}${if_up ppp0}${downspeed ppp0} kb/s / ${totaldown ppp0}${endif}

${goto 373}${voffset -162}${font Dingytwo:size=17}M$font 
${goto 373}${voffset 7}${font Dingytwo:size=17}7$font 
${goto 373}${voffset 1}${font Dingytwo:size=17}O$font 
${goto 373}${voffset 1}${font Dingytwo:size=17}5$font 
${goto 373}${voffset 1}${font Dingytwo:size=17}4$font

I've tried many values for the own_window_type param, but none fixed the issue. Does somebody know how to achieve this, or what are the others environment factors that affect how the .conkyrc param must be set ?

6

-You just define:

  own_window yes
  own_window_transparent yes 
  own_window_type conky
  own_window_argb_visual yes 
  own_window_class override

...and you can get the transparency on the desktop.

  • greeeat man!! thank you finally the transparency!! there are the important things of life XD – lese Oct 29 '15 at 16:05
  • 1
    @lese Note that you probably don't want own_window_type conky, that lets you move the conky window around with Alt+click. I would stick with own_window_type desktop instead. All you need to do is add own_window_argb_visual yes to your existing conkyrc file. – terdon Oct 29 '15 at 16:06
  • nice addition terdon , I did not know I could move it around, but I see it usefull in one way, the cases when desktop files are saved and placed under conky, I cannot select them. I will let the own_window_type conky param this way I can still move it and grab the file : ) – lese Oct 29 '15 at 16:13
  • 1
    Hello @lese I'm sorry for all this time without giving you a return, an answer, but I found here the question of conky on the desktop and hide all windows "desktop items" he was going along the only way to keep it on the desktop is same setting on the "own_window_type dock" as dock even the problem is that so alignment should be made more defined with the "gap_x" and "gap_y" to better define the position on the desktop, so the desktop so it can hide all the windows with the button hide all desktop items and conky remains active on your desktop. – Joke Sr. OK Dec 15 '15 at 1:19
  • 1
    Many thanks Paulo, and don't worry about the time passed, it was a very minor issue : ) with your last comment I was able to obtain what I was looking for, thx – lese Dec 15 '15 at 9:27
1

you can also try the options

own_window class override

own_window_hints below, undecorated, sticky, skip taskbar, skip_page conky that will keep away from the taskbar and other things ...

...and are this other classes of the WINDOW of conky can use it!

normal, override, desktop

you can use one of this 3 kinds

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.