2

I am trying to use rsync to sync files from my laptop (Ubuntu 14.04) to an external disk. When connecting the disk I start the sync with the following command:

rsync -av --delete /home/alexander/10_Private /media/alexander/LACIESHARE/Backup

It starts fine, but later on every transfer faild because I do not have write permission on the disk any more; here part of the output of the rysnc command:

....
10_Private/Vodafone/contract.jpg
10_Private/Vodafone/letter2.pdf
rsync: mkstemp "/media/alexander/LACIESHARE/Backup/10_Private/Swiss/.Oeffnungszeiten.pdf.pKmrxs" failed: Read-only file system (30)
rsync: mkstemp "/media/alexander/LACIESHARE/Backup/10_Private/Swiss/COOP/.Adressaenderung.pdf.zCxEJn" failed: Read-only file system (30)
....

How is it possible that rsync suddenly changes the file-system of the external disk to 'read-only'? What is going on, and how to fix this behaviour?

During the sync, I have nothing done regarding the external disk; no other file copy, file access...

6

The drive is probably mounted with the errors=remount-ro option, AND there are read or write errors while running the rsync. That option causes the drive to be remounted as read-only if there are any read or write errors detected.

This could be caused by a bad connector or cable, bad port (e.g. USB or esata), or because the drive itself is failing.

In other words, it's probably a hardware fault.

  • This makes sense, but I cannot see this mounting option: /dev/sdc1 on /media/alexander/LACIESHARE type vfat (rw,nosuid,nodev,uid=1000,gid=1000,shortname=mixed,dmask=0077,utf8=1,showexec,flush,uhelper=udisks2) – Alex Oct 28 '15 at 10:10
  • 1
    errors=remount-ro is the default for FAT filesystems. man mount, search for FAT.*error – cas Oct 28 '15 at 10:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.