2

I am on Debian Jessie. I just wanted to install Nvidia drivers. But I found nvidia-detect does not detect my dedicated chip. Although it is listed in lshw.

lshw -c video before any installation

# lshw -c video
  *-display               
       description: 3D controller
       product: GK107M [GeForce GT 750M]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list rom
       configuration: driver=nouveau latency=0
       resources: irq:51 memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:f7000000-f707ffff
  *-display
       description: VGA compatible controller
       product: 4th Gen Core Processor Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 06
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:49 memory:f7400000-f77fffff memory:d0000000-dfffffff ioport:f000(size=64)

lshw -c video after installation and uninstallation of Nvidia drivers and blacklisting nouveau -> upon request

$ lspci | grep VGA

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)

$ lspci | grep NVIDIA

$ lspci | grep NVIDIA
01:00.0 3D controller: NVIDIA Corporation GK107M [GeForce GT 750M] (rev a1)

$ lspci -vnnn | egrep 'VGA|NVIDIA'

$ lspci -vnnn | egrep 'VGA|NVIDIA'
00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06) (prog-if 00 [VGA controller])
01:00.0 3D controller [0302]: NVIDIA Corporation GK107M [GeForce GT 750M] [10de:0fe4] (rev a1)

Notice, the Nvidia is not listed under VGA.

So, the HW is detected.

But I installed Nvidia drivers according to this http://linuxconfig.org/nvidia-geforce-driver-installation-on-debian-jessie-linux-8-64bit and rebooted (into console) and ran nvidia-detect

AND IT SAYS

nvidia-detect

# nvidia-detect
No NVIDIA GPU detected.

I am unable to startx, it ended up with an error. In the log I saw No screens detected or similar.

So, what is wrong? Is the dedicated chip dead?

  • what does lspci | grep VGA show? – cas Oct 28 '15 at 7:44
  • 1
    you have one of those switching dual GPU laptops. iirc you need to install something called bumblebee to get it to switch modes. you also need the proprietary driver...it's a recent GPU so the latest driver package (i.e. not the legacy driver package) should work. on debian sid, that would be nvidia-driver. dunno about other distros. – cas Oct 28 '15 at 7:52
  • on further reading about it, it seems that bumblee is no longer needed. recentish (>=2014) nvidia-settings can detect and switch, so you need nvidia-settings as well as nvidia-driver – cas Oct 28 '15 at 7:54
  • 1
    Now days optimus NVIDIA cards are little bit difficult to handle then they were before, specially with new UEFI hardware. Though its late, please have a look there if you want to configure your card with non-free nvidia driver, I'hv written one article about it. fixmynix.com/… – Arnab Nov 6 '15 at 17:13
1
+50

I think the reason you're having problems is that your video card requires the proprietary nvidia 352 driver and the only driver available in the jessie, jessie-backports, and sid repositores is the version 340 driver. You should check on the Nvidia website drivers page to verify the version your card requires.

The proprietary version 352 driver is currently available only in the Debian experimental repository. I've pulled it down and built the package on jessie. It's a noodle soup of dependency problems and will be a major task to install it in jessie (at least with my knowledge of the situation).

That leaves two options: install the free drivers, or let the nvidia installer loose on your system. Both Debian and Arch (haven't checked others) and I strongly recommend against installing the proprietary drivers outside of the respective package management system

If this was my system, I would install the free drivers and wait for the packages in experimental to make it to sid or jessie-backports before trying again.

This from the Official Debian Wiki NvidiaGraphicsDrivers page:

As of jessie, the need for the proprietary drivers is pretty much over - nouveau now works quite well and works with dual-headed displays by simple and easy configuring from within your desktop. The proprietary drivers don't provide normal logging and can be a hidden source of problems. If you are doing a distribution upgrade - you should at the very least remove all the nvidia packages from wheezy - get your desktop working with nouveau - then reinstall the nvidia packages if there is a pressing reason.

I would follow the directions on the Official Debian Wiki Bumblebee page and make sure to install the bumblebee package not bumblebee-nvidia.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.