I decided to update Mint today, and Cinnamon fails to load after the login screen, and can never successfully restart. I also have no terminal; I cannot see text, and I cannot type anything. I just see a black screen with a moveable mouse cursor. How can I start the terminal in fallback mode?

Edit: I forgot to mention my Mint's update manager failed some of the updates. Cinnamon didn't crash then, it just continually went into fallback mode after restarting my computer.


It doesn't seem possible for me to view the terminal after logging in with cinnamon, but ctrl-alt-f2 at the login screen opened up a terminal session.

Edit: I have also solved my Cinnamon never coming out of fallback mode by running sudo apt dist-upgrade


The CTRL+ALT+F_ method cannot be used for Virtual machines running inside a Linux host. Using the hotkey opens the background terminal on the host machine instead. I had to wait for the desktop icons to seemingly randomly show up. After this I could open the terminal using the right click menu. Then I was able to fix the problem using the terminal.

In my case the problem was that during installation of some packages, I ran out of space (due to the bug in VirtualBox where it refuses to increase the dynamic disk). This lack of space interrupted the installation of two packages, and two packages were left in a kind of limbo state where they could not be installed and did not work. Apparently, Cinnamon depended on one or both or these. The solution was to run this command:

sudo apt-get install -f

This finishes the installations that are in limbo. After this, I restarted the system and it was back to normal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.