I have received a computer that the previous owner had attempted to install some Linux OS, I don't know which particular one. I have both an Ubuntu and a Windows bootable USB drive and I have attempted to boot off of them with priority set to boot off USBs in the BIOS, however when computer boots it leads me grub rescue prompt. Multiple occasions I have tried to boot off the USBs but the same result ensues.

At the very beginning of the prompt it displays:

"error: no such device: 79078212-7a47-4a0a-a07a-ee451a023492."

Followed by:

"Entering rescue mode..."

"grub rescue>"

1 Answer 1


If you're getting the same error on both a Windows USB and Linux USB stick then it's unlikely that the USB stick is being used to boot. The 'no such device' error message should be a UUID that should be different between the two operating systems (that and Windows doesn't use GRUB). To me this indicates one of two things, either there's a problem with the BIOS boot order and the USB sticks are being skipped, or the order is correct but there's a problem with both USB sticks and the local hard drive is next on the list of devices to boot from.

From the BIOS boot screen there's usually a method of changing the boot order at boot time or booting off a specific device - usually pressing F12 or F1 or some key other than getting you into the BIOS configuration. I'd recommend finding that, and trying to boot from the Windows USB to start. If you continue getting the same grub message, I'd try the USB sticks in another system to make sure they're readable.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .